0

Recently I took a lenovo g500s laptop. the product id is LENOVO_MT_20245. after the installation, it could not recognize LAN network adapter. After googling I found out that it has a Qualcomm Atheros AR8172/8176/8178 PCI-E Fast Ethernet Controller

Command lspci -nn | grep 0200 says:

01:00.0 Ethernet controller [0200]: Qualcomm Atheros QCA8172 Fast Ethernet [1969:10a0] (rev 10)

Anybody know a way to fix this driver?

2
  • Please edit your question to add details of your ethernet card from the terminal command: lspci -nn | grep 0200 – chili555 Sep 8 '13 at 13:59
  • 01:00.0 Ethernet controller [0200]: Qualcomm Atheros QCA8172 Fast Ethernet [1969:10a0] (rev 10) – Hiranya Samarasinghe Sep 8 '13 at 14:02
2

[SOLVED]

first enter lspci -nn | grep 0200 and make sure that your drivers is "Qualcomm Atheros QCA8172 Fast Ethernet[1969:10a0]"

The following fix is is only going to work for-

1969:1091 - AR8161 Gigabit Ethernet
1969:1090 - AR8162 Fast Ethernet
1969:10A1 - QCA8171 Gigabit Ethernet
1969:10A0 - QCA8172 Fast Ethernet

adapters. and please make sure that your kernel is 2.6.24 or above. It is technically possible for kernels < 2.6.24 but might take some work. (still worth giving a try!) to check the kernel version type

uname -a

after that, If they are all neat and right. download compat-drivers-2013-03-04-u.tar.bz2 file and extract it. go to the extracted directory [ex- cd Downloads/compat-drivers-2013-03-04-u/] and type-

sudo ./scripts/driver-select alx

sudo make

sudo make install

reboot the system you are all done :) apparently this type of ethernet adapters are available in lenovo g500s, lenovo g500 series, lenovo g400 series, asus 3rd gen laptops, (you better check before installing)

for more information go to http://www.linuxfoundation.org

Thanks to Lusus Naturae. His forum showed me this way. so the rewards goes to him. [original link-] http://meinewenigkeit.blogspot.com/2013/08/gentoo-and-atheros-qca8172-fast-ethernet.html

0

Your device 1969:10a0 is covered by the driver alx by default in Ubuntu 13.04. I suggest you upgrade to 13.04.

-1

The compile errors are basically redefinitions of already defined functions. For me, I was on Kernel 3.2.x and in the include/linux/compat-2.6.h file I just commented out everything after #include , because the compile errors were in 3.4, 3.7 and 3.8. So basically I commented out all lines from include compat-3.4.h thru compat-3.9.h. After that the compile and the install worked.

Hope that helps, Denis.

1
  • 3
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Aug 2 '16 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.