I need to sniff all the wifi traffic that I can capture using wireshark in Ubuntu. My wireless interface is named as eth1 in the interfaces list. When I select that interface in Wireshark and start new sniff, I got following error;

enter image description here

As this thread says, I tried to installed the mentioned driver but I got an error in installation saying that that driver is not supported by my device. After that I tried the second answer in the same thread and run following command to enable monitor mode in my wireless card.

echo 1 > /proc/brcm_monitor0

Then I saw a new Ethernet interface (not a wireless interface ) called prism0 in wireshark interface list. I couldn't start a sniff using that interface using monitor mode because in that interface settings, monitor mode check box has been disabled.

I have installed a broadcom wireless driver in Additional Drivers as follows:

enter image description here

Is there an error listing my Wifi interface as eth1 rather than wlan0 in the interfaces list? How can I start my wireless interface in monitor mode for sniffing?

Thank you.

  • The correct interface for the Broadcom STA driver is eth1. There is no error. – chili555 Sep 8 '13 at 13:44
  • @chili555 I recommend posting something like that as an answer. – Eliah Kagan Sep 8 '13 at 18:50
  • @chili555, I found an answer myself and posted as an answer :) You are correct. There's no error displaying wlan0 as eth1 with STA driver. :) – Deepal Sep 8 '13 at 18:52

Finally I found a solution by little research. The problem was really with the device driver I had chosen in Additional Drivers as the image shows in the question. I then selected the second choise in wireless drivers which is "Do not use this device". It doesn't have the meaning it implies, it only does avoid using broadcom wireless STA driver. Then I restarted my machine and I could see my interface as wlan0 (which was previously displayed as eth1).

Then I executed following command (airmon-ng bash script), which I could easily turn wireless card into monitor mode.

sudo airmon-ng start wlan0

enter image description here

It was required to start monitoring mode of the wlan0 interface using airmon-ng script before sniffing. Otherwise when I start a sniff using wlan0 with wireshark(monitor mode enabled in wireshark) I could only sniff few seconds and automatically device disconnects from the network.


First, I have limitied experience with Wireshark on Ubuntu.

I had problems getting Wireshark to work. Got all interfaces to show when I started Wireshark as sudo user:

sudo wireshark

Hope this helps!

  • 2
    In my case I can see all interfaces in wireshark with no error. I think you need to add your username into wireshark user group, and then you won't need to run wireshark as root. I found the solution for my case by little research and I'll post it as an answer. Thank you very much for replying my question :) – Deepal Sep 8 '13 at 18:41
  • Running wireshark as root is definitely not recommended. – guntbert Jun 20 '15 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.