25

I know Byobu is a terminal multiplexer and mouse is not a priority, but I still would like to know if there is a way to focus on a split using mouse click instead of keyboard shortcuts.

In negative case, it certainly would be a great feature.

36

Yes, this is very much possible.

You simply need to turn on mouse support in your ~/.byobu/.tmux.conf configuration.

Add the following:

set -g mouse-select-pane on
set -g mouse-select-window on
set -g mouse-resize-pane on
set -g mouse-utf8 on

This will allow you to:

  • select a split by clicking in it
  • select a window by clicking on it in your status bar
  • resize a split by grabbing the border and dragging

However, you may now find it difficult to use your mouse to click on some text, and highlight (select) it. To do this, you'll now need to use either Shift-LeftClick or Ctrl-LeftClick.

Full disclosure: I am the author and maintainer of Byobu.

  • Does it work with byobu 5.21 tmux 1.7? I edit ~/.byobu/.tmux.conf, opened a new terminal with byobu but still can't have mouse interaction. – marcio Sep 9 '13 at 14:51
  • 2
    Ok. It's working now, I just had to restart my terminal :) Thanks! – marcio Sep 9 '13 at 17:01
  • 1
    this doesn't work anymore in Ubuntu 16.04 I guess. I keep getting unknown option for each of one of these options. Am I doing it wrong? – Maziyar Apr 26 '16 at 8:11
  • 3
    No longer works. See comment below from jig – jdpipe Mar 8 '17 at 7:26
17

In Ubuntu 16.04 this solution no longer works. It seems that config has changed in tmux new version (from tmux 2.1 and up).

Now you must copy (append) the following in your ~/.byobu/.tmux.conf file:

set -g mouse on
set -g mouse-utf8 on
  • This also works when running tmux on OS X – boris quiroz Aug 26 '16 at 20:30
  • This works on Ubuntu 18.04 as well – jig Jun 3 '18 at 9:57
1

for me, neither of the above solutions seemed to do anything.

Restarting the terminal session, and restarting byobu with those settings in the config file did nothing.

One magic keypress changed all that:

Ctrl+F12 and you get the message "Mouse: ON"

(Ubuntu 18.04, tmux 2.6, byobu 5.125)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.