This question already has an answer here:

I installed (partially) TeamViewer but the installation did not complete because dependency errors. Teamviewer depends on ia32-libs which depends on ia32-libs-i386. The dependency tree can get quite long.

I tried running sudo apt-get install -f to no avail. Please if anyone has tips on installation help me.

As suggested the output of sudo apt-get install -f is

More problems to get a complete view of this problem. I tried this dpkg --add-architecture i386 but dpkg says

dpkg: error: unknown option --add-architecture

so might the problem be with dpkg?

marked as duplicate by Lucio, Seth, karel, blade19899, user117103 Dec 17 '13 at 21:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Could you post what does sudo apt-get install -f exactly say at the moment? – Vadim Peretokin Sep 8 '13 at 8:40
  • @Vadi I edited it see above – mojo706 Sep 8 '13 at 18:35
  • as you can see I enter the command and see that. I remove teamviewer and then try and re-install. Its a cycle :( – mojo706 Sep 8 '13 at 18:44
  • Make sure you need the 32 bit version. I has similar problems and tracked it back to running the 32 bit instead of the 64 bit version. – crafter Sep 8 '13 at 19:13
  • I need 64bit but I can't find them – mojo706 Sep 8 '13 at 19:19

Do what it says - type Y. Then download the 64bit .deb from https://www.teamviewer.com/en/download/linux.aspx, double-click on that and install that - it'll work.

  • I tried that. The one I have is the 64 bit version. I have tried everything you have asked. – mojo706 Sep 9 '13 at 12:00
  • What is the mentioned dependency tree, then? You haven't posted part of the output and only what you see when you have to remove the package due to incomplete dependencies. – Vadim Peretokin Sep 9 '13 at 20:24
  • here are the dependencies. paste.ubuntu.com/6087054 – mojo706 Sep 10 '13 at 9:03
  • Try the accepted answer here: askubuntu.com/questions/216845/… – Vadim Peretokin Sep 10 '13 at 11:23
  • Nope no help there. I tried installing the said package for 12.04 but it did not work. – mojo706 Sep 10 '13 at 11:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.