4

This question already has an answer here:

I am newbie with Ubuntu and I am using Ubuntu 12.04.3 LTS version inside Windows using WUBI.

I have to install few softwares in Ubuntu which are as follow:

  • MPLAB X IDE version 1.90
  • XC8 Compiler and X32 Compiler
  • Cadsoft from Eagle

I download there setup files, which are having extension *.run extension.

I searched on Internet and found that these files don't have executable permission, either one have to do it graphically by right clicking on the file and then under permissions tab check the Allow executing as program check box, or use chmod command to do so. I had tried everything but nothing works for me.

I used graphical method to change this, but as soon as I click on the check box, the check mark disappears. I tried command line methods too but nothing works for me:

sudo chmod u+x MPLABX-v1.90-linux-installer.run
sudo chmod +x MPLABX-v1.90-linux-installer.run
chmod +x MPLABX-v1.90-linux-installer.run
sudo chmod 777 MPLABX-v1.90-linux-installer.run

When run:

sudo ./MPLABX-v1.90-linux-installer.run

the result is command not found.

sudo "./MPLABX-v1.90-linux-installer.run"

results in command not found.

I tried all these commands but nothing changes the permission to executable. Please help me as soon as possible.

marked as duplicate by Mitch, Alaa Ali, Kevin Bowen, stephenmyall, Mahesh Sep 16 '13 at 9:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you print the output of the 'file' command on that file? 'file ./MPLABX-v1.90-linux-installer.run' – Scott Salley Sep 8 '13 at 6:08
  • 2
    Are these files on a NTFS drive? Only Linux filesystems support marking as executable – kiri Sep 8 '13 at 6:08
  • Hello!! Scott Salley, how to print the output, i am new thats why i dont know. you tell me the instruction, i will do so. What i think is that the problem is with OS part as i am having 4 files to install and all are behaving in similar manner. – xpress_embedo Sep 8 '13 at 6:18
  • hello!! minerz029, i am using wubi to install Ubuntu 12.04.3 and yes they are on NTFS partition. How to solve my problem, if they are on NTFS – xpress_embedo Sep 8 '13 at 6:20
  • @xpress_embedo It's a little difficult to make NTFS files executable, but see my answer for a few workarounds. – kiri Sep 8 '13 at 6:51
10

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, navigate to the directory of the .run file, and run the command(s) below:

chmod +x example.run
sudo ./example.run

OR

Right-click the file and select Properties. Under the Permissions tab, make sure that Allow executing file as program is checked and press Close. Double-click the .run file to open it. A dialog box will appear, choose Run in Terminal to run the installer

A Terminal window will open. Follow any instructions on-screen to install the program.

Note:64-bit versions of Ubuntu don't include the 32-bit libraries required to run the installer. Before the installer will run, you need to install the ia32-libs.

  • Will the first one work ,since ./example.run is not in secure-path of sudo? – Stormvirux Sep 8 '13 at 6:32
  • It should work as is, if not then you can force it by using Radu's answer. – Mitch Sep 8 '13 at 6:41
  • 1
    Please read my first post. I had tried all this method, but nothing works. Because my chmod command isn't changing the permission of the file. When doing this graphically, when i check the allow program as executable, it disappears as soon as i click on it. I had written this in my first post. – xpress_embedo Sep 8 '13 at 7:01
  • 1
    Thanks it works... I installed ia32-libs and finally my setup is running. – xpress_embedo Sep 8 '13 at 8:01
1

Try with the following commands:

cd ~/Downloads
chmod +x <file>.run
sudo sh ./<file>.run

assuming that you downloaded your files in ~/Downloads directory.

  • I had tried this, but dont add sh in sudo command. But still doesn't works – xpress_embedo Sep 8 '13 at 6:59
  • @xpress_embedo So, what is the output of sudo sh ./MPLABX-v1.90-linux-installer.run command? – Radu Rădeanu Sep 8 '13 at 7:06
  • @radu-rdeanu I got this sharma@ubuntu:~/Downloads$ sudo sh ./MPLABX-v1.90-linux-installer.run [sudo] password for sharma: ./MPLABX-v1.90-linux-installer.run: 1: ./MPLABX-v1.90-linux-installer.run: Syntax error: "(" unexpected – xpress_embedo Sep 8 '13 at 7:18
  • @xpress_embedo You should try using sudo bash ./MPLABX-v1.90-linux-installer.run instead, as bash is different from sh (sh is a symlink to dash) – kiri Sep 8 '13 at 7:24
  • @xpress_embedo As minerz029 said, you can try with bash instead sh. But I think that there is a problem with your downloaded file. So, try to download again! – Radu Rădeanu Sep 8 '13 at 7:38
0

I used graphical method to change this, but as soon as I click on the check box, the check mark disappears

Sorry, but I think all the other answers are wrong.
Here are my solution(s), in order of preference:

  • You might be able to run it with sudo bash ./MPLABX-v1.90-linux-installer.run, assuming that it should open with bash.
  • Try using these commands (source):

    for 64-bit programs: sudo /lib64/ld-linux-x86-64.so.2 ./MPLABX-v1.90-linux-installer.run
    for 32-bit programs: sudo /lib/ld-linux.so.2 ./MPLABX-v1.90-linux-installer.run

  • You could create a small ext4 partition, place the file there and give it executable status

  • You could remount the partition this file is on and make all the files on it executable, see here

  • I will see this method. But i want to tell one thing, the software which i am trying to install are present on the hard disk formatted with NTFS. I think this was the reason i am not able to change the permission. I copied the *.run file into the downloads folder and changed its permission, and it works, but when i tried to run it, no error and nothing appears. – xpress_embedo Sep 8 '13 at 7:10
  • @xpress_embedo be sure to report back which method works for you and note that the last solution, I think is not possible (seeing as it is the system / drive) but I put it there for completeness – kiri Sep 8 '13 at 7:12
  • Till now no method works, but i am able to change the permissions of file, but when i click on the file, nothing happens, no error nothing. – xpress_embedo Sep 8 '13 at 7:15
  • @xpress_embedo try running it with this command sudo bash ./MPLABX-v1.90-linux-installer.run in terminal – kiri Sep 8 '13 at 7:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.