I installed Xampp for Ubuntu 12.04. I was able to reach the Xampp splash page/index page. Then, when I clicked on myphpadmin, it wasn't working and I would get an error page.

So instead I tried restarting my computer. After restart I assumed Apache had to be restarted. So, I went to opt/lampp and typed lampp start. Nothing happens and I just get the directory and cursor again in my terminal. Below is the snippet.

root@ubuntu:/opt/lampp# lampp start
lampp: command not found
root@ubuntu:/opt/lampp# 

Anyone have any clues?

Thank you!

  • what is the output for ls in the directory,:) – rɑːdʒɑ Sep 8 '13 at 4:20
  • how you have installed xampp ? – rɑːdʒɑ Sep 8 '13 at 4:21
up vote 7 down vote accepted

This is happen when you don't give the correct path for the script. You should start XAMPP using:

./lampp start

or

/opt/lampp/lampp start

If you are not logged as root, you can use:

sudo /opt/lampp/lampp start

And if you add your /opt/lampp directory to your PATH, after you can start it with:

sudo lampp start
  • Thank you very much. i needed the "./lampp start" to work. oh and btw phpmyadmin works now too. I jumped for joy. Thank you very much. Now i'm off to gettin Drupal working. Have a good day! – Daniel Miladinovich Sep 8 '13 at 4:27

I dont know how you have installed XAMPP in your Ubuntu , but I am giving the working way which I have tried personally in my Ubuntu PC.

just open your terminal and type as

wget http://www.apachefriends.org/download.php?xampp-linux-1.8.3-1-installer.run
chmod +x xampp-linux-1.8.3-1-installer.run
./xampp-linux-1.8.3-1-installer.run

after finishing the execution , just do as

sudo  /opt/lampp/lampp start

enter image description here

  • Thanks this worked. the issue was that i was neglecting the './' infront of lampp. – Daniel Miladinovich Sep 8 '13 at 4:26
  • @ZealotSveta glad to hear that. Enjoy Ubuntu. :) – rɑːdʒɑ Sep 8 '13 at 4:28

try this

sudo service mysql stop
sudo /opt/lampp/lampp restart

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.