How do you mount a Motorola Xoom in Ubuntu to sync your music? I recently purchased one, and unlike my other Android devices, it doesn't seem to want to mount. I tried using a Windows computer to sync the music but the services aren't as well refined as what we see in Banshee (especially with metadata and album art).


Well, it's necessary little tweaking to enable it, here we go!

Enabling Motorola Xoom as storage device in Ubuntu

First you will need to install mtpfs package to the whole process work.

sudo apt-get install mtpfs (Lucid users may need to use Maverick/Natty repositories or compile from source mtpfs due to broken package)

After you have installed it you need to tweak a little to Ubuntu recognize Xoom as a USB device.

sudo gedit /etc/udev/rules.d/51-android.rules , in the file that will open add these lines: (it's important to don't repeat IDs, if you already have any of these IDs into this file just don't add the repeated ID's line)

SUBSYSTEM=="usb", ATTR{idVendor}=="22b8", MODE="0666"
SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", MODE="0666"
SUBSYSTEM=="usb", ATTR{idVendor}=="70a8", MODE="0666"
SUBSYSTEM=="usb", ATTR{idVendor}=="70a9", MODE="0666"

Save the changes and close it, open a new terminal to changes make effect and then you need to make the mount point and take ownership of it.

sudo mkdir /media/xoom

sudo chown user:user /media/xoom ( ! Make sure to replace the "user" with your username (in my case: sudo chown rodrigo:rodrigo /media/xoom)! )

At this point you already can mount it by typing mtpfs /media/xoom -o allow_other and unmount by typing fusermount -u /media/xoom , but it's not the best way, yes? If you agree with me continue following the steps!

Now add the mount point to your fstab.

sudo gedit /etc/fstab , in the file that will open add the following:

# mount point for moto xoom
mtpfs     /media/xoom     fuse     user,noauto,allow_other      0      0

You're almost there, now open fuse.conf.

sudo gedit /etc/fuse.conf , in the file that will open uncomment ( delete the character "#" in the beggining of the line) this line:


Save the changes, close it and go on to the last step!

You now just need to add your user to the fuse group.

sudo gedit /etc/group , in the file that will open ( how many times I already wrote this? ) add your user name to the fuse line ( you can hit Ctrl + F to look for the word "fuse" ). Many have doubts here, so here is MINE exemple:


Sure that you won't write "rodrigo", but your username, OK? Just Save the changes and close it.

Finally ( many steps, yeah? ), Restart your machine! Now when you look at your Places in Nautilus there will be a drive named "xoom" and you will just need to plug-in your tablet and play with the files, to unmout just right click on the icon and select to Unmout.

Really, I made my best to summarize the steps, hope very much it will work for everybody!

  • It didn't work, but I heard this does work under 32-bit, but I appreciate the effort!
    – Grayson
    Jul 17 '11 at 18:42
  • Oh! I'm under 32-bit and I can't try to change some code to it make effect under 64-bit because I don't know how to deal with 32/64-bit differences, sorry I can't help you. Jul 20 '11 at 0:18
  • Re-reading my answer I think I was not too clear when I said "replace the 2 'user' with your username", I meant to replace it like: "rodrigo:rodrigo", NOT only the second: user:rodrigo. I already edited the answer to make it clear. Jul 20 '11 at 15:29
  • Instead of editing /etc/group, you could use adduser rodrigo fuse.
    – elmicha
    Nov 21 '11 at 21:32
  • it kind of worked for me.. I am on a 64bit 11.10 and my xoom (with usb debuging on) mounted and I was able to create a folder but had a weird behavior when files where copied: they appeared and then disappeared.. I managed to transfer from the command line and after the copy listing (ls -l) the file. This taked a long time but then it listed the copied file and it did not vanish again.
    – lpanebr
    Apr 9 '12 at 11:54

In Honeycomb, Android switched from USB Mass Storage to MTP as the protocol for transferring files.

Try installing the package mtpfs (you may do so from the terminal), and make sure that in your preferences for Banshee you have MTP support checked in the extensions list.

Should that not work and you have to get more in depth, you can find all the information you need at this website.

Good luck!


I found Rodrigo's instructions allowed me to mount my Android 3.1 Xoom on 64-bit Kubuntu 11.04. I just have 2 comments ...

  1. /etc/udev/rules.d/51-android.rules - lines 3 and 4 ("70a8" and "70a9") are Product Id's for the Xoom. I can remove lines 3 and 4 and the Xoom still mounts.
  2. /etc/fuse.conf - I found I needed to make this change before I could mount the Xoom from the command-line using mtpfs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.