3

My Ubuntu 13.04 is not working after boot since I installed some applications. The graphics used to be better before this happened . My keyboard and my mouse aren't working . I'm using a desktop (Nec power mate). My keyboard and mouse work perfectly on other computers.

3
  • 1
    press ctrl+alt+f1 and check whether you are able to go to tty1 CLI mode. Reply.. Sep 7, 2013 at 10:26
  • 2
    Dude… my keyboard isn't working I can't type anything … helpppp me… Sep 7, 2013 at 11:20
  • Hope in Recovery Mode your keyboard works.. Since the suggestion was so long, I described it as an answer.. Check my answer.. Sep 7, 2013 at 12:03

3 Answers 3

4

You can give a try to fix your problem using Recovery Mode(Safe Mode) if nothing helped

Hopefully your keyboard works in Recovery Mode.

  • When your system starts chose Recovery Mode (2nd option in grub menu).
  • From the Menu just go to Grub option, it will give a message like Updating grub will mount your system in read/write mode. Choose yes to mount your system in read/write mode. It will update your grub and will exit from Grub menu.
  • chose network option, it may enable your network (it could take some time.).
  • Then chose dpkg menu from the list, chose yes for all.
  • Finally choose root option and log in. Execute the following commands one after another:

    apt-get autoremove
    apt-get autoclean
    apt-get update
    apt-get -f install
    apt-get dist-upgrade
    apt-get upgrade
    

    Also try to remove those package that you installed and caused such problems if you remember their names. Use these commands to remove:

    apt-get autoremove your_package_name
    apt-get --purge remove your_package_name
    

    Then again repeat above mentioned 6 commands. Then reboot your system and check whether your are able to use Ubuntu or not. Run this command to reboot:

    reboot
    
5
  • 1
    about removing package, you should add *be sure that you are not removing Graphic Card drivers without installing the free drivers sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 xserver-xorg-core sudo dpkg-reconfigure xserver-xorg, otherwise after reboot it would be worst!
    – Boris
    Sep 7, 2013 at 14:15
  • Thanks guys ~ I went into recovery mode and fixed it from there :)) Sep 8, 2013 at 1:36
  • then mark this as solved.. so that it would help others.. Sep 8, 2013 at 6:45
  • 1
    Sounds like the menu order has moved around a bit since this post. Network is now on the top menu, at least for me. But this post helped me at least get somewhere... thanks! Mar 20, 2015 at 20:18
  • Still not working in my scenario :( Jun 15, 2015 at 4:44
0

I have an AMD A6 processor on a Toshiba Satellite L775 laptop and did a complete install of Ubuntu 12.04 from a livecd, have upgraded eventually now to 13.04, and have had this keyboard and mouse issue the whole time.I'm knew to Ubuntu and I've found that there are a ton's of people that continually have this same issue as me with a thousand and one different advices, that are way over my head of how to fix the problem. This process that I just followed might be something that could be the first recommended thing to do when ever someone has a problem after an update or install.

I used part of this info above to help me fix my keyboard an mouse not working issue. First I Held down the shift key when rebooting to get to grub menu. Then I Chose second option in that menu. Then once again chose the second option, I believe, in another menu that opened up. Eventually I came to a screen that had several options of what I wanted to do. I opened the network first. After that process ended I chose update grub. When that finished I then selected an option to something to the effect of fixing any broken software that wasn’t installed right. I ran this last option twice.

I'm hoping the Ubuntu Gurus can clean up my wording for precise menu functions that I chose from the various menus that I selected but, I think someone will get the gist of what I’m try to relay from this post.

Good luck.

1
  • 1
    I'm lost at the 2nd 2nd option. ;) screenshots or photos would improve this answer and show everyone what you mean and give reviewers options for improvment.
    – LiveWireBT
    Oct 29, 2013 at 8:15
0

Gotta love the escape key. I have dual boot win7/ubuntu14.04LTS. Hold down the escape key during the ubuntu boot. You may have to release key momentarily during ubuntu boot (if you see listings on black screen during ubuntu booting), then hold the escape key down and move mouse until you see the mouse icon moving on the ubuntu screen. Dude you should be able to type now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.