I am using curl -L https://get.rvm.io | bash -s stable to install RVM. I get an error saying

CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none

I searched a bit on the Internet and found that changing the permissions of /etc/pki/tls/certs/ca-bundle.crt should get the job done. But whole /etc/pki directory is missing from my system. How can I fix it?


On ubuntu/debian, this file is in /etc/ssl/certs/ca-certificates.crt. You could symlink it. The /etc/pki/ path is used on Redhat.

  • 1
    i have ubuntu 15.04 n faced the issue while installing the web app framework: meteor.js(curl install.meteor.com | sh) I fixed it as you instructed. But which command or tool is looking for certificates in /etc/pki if this convention is going on for so many years? – Anurag Priyadarshi Jul 8 '15 at 5:14
  • 1
    Different Linux distributions use different paths. Debian uses one, RedHat another. – cweiske Jul 8 '15 at 6:27
  • This saved my life! Tnx :) – Ehsan M. Kermani Nov 24 '15 at 21:57
  • can you please elaborate the steps? i am kind of lost as to what commands I have to enter in the terminal here. – MycrofD May 1 '16 at 5:12

Simply create a ~/.curlrc file.

Then add the following lines to the file:


Feel free to adjust those paths as necessary, as different Linux distributions may use different paths.

(Worked for Ubuntu 14.04).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.