My chromium browser doesn't work for some reason. What I mean by that is that it doesn't even start up when I click on chromium icon or choose chromium from applications menu. What might be the problem?

After typing: chromium-browser in the terminal I get this:

/home/freshnrg/.themes/T-ish-Brushed-Overlaid/gtk-2.0/gtkrc:56: Clearlooks configuration option "sunkenmenu" is not supported and will be ignored.
/home/freshnrg/.themes/T-ish-Brushed-Overlaid/gtk-2.0/gtkrc:57: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
/home/freshnrg/.themes/T-ish-Brushed-Overlaid/gtk-2.0/gtkrc:58: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
/home/freshnrg/.themes/T-ish-Brushed-Overlaid/gtk-2.0/gtkrc:59: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
Segmentation fault

So nothing about any errors connected to chromium because all that is just my ubuntu theme errors witch i get all the time. don't understand that Segmentation fault not sure if that has anything to do with chromium.

after typing: rm -rf ~/.config/chromium and then: chromium-browser

chromium actually starts from scratch asking if I want to import bookmarks from firefox and it doesn't matter what I choose because that is it. After that nothing happens and chromium still doesn't work.

Re-installation didn't helped. I still get segmentation fault error.

EDIT: I've done all this, went back to official version 5.0.375.127, I've re-installed it couple of times and still nothing. I still have that segmentation fault error.

EDIT: It's definitely something to do with dropbox. After installing dropbox on my new account Chromium stopped working. How can I get rid of dropbox on my old account as I've uninstalled it and deleted all the files that has anything to do with dropbox but I still can't get Chromium to work?

  • Try opening a terminal and typing chromium-browser and pressing enter to see if it gives any error messages. – LassePoulsen Sep 1 '10 at 13:14
  • Have you tried re-installing chromium-browser? – Marco Ceppi Sep 1 '10 at 13:27
  • @Marco Ceppi: that's "chromium-browser", not just "chromium". "chromium" is a dummy package that actually links to "chromium-bsu", a shoot-em-up game :) – Little Jawa Sep 1 '10 at 13:35
  • @Jawa: one of the best shoot-em-ups for linux! ;D – Marco Ceppi Sep 1 '10 at 13:55
  • @Marco: YES ! :-p @Freshnrg: I edited my answer. – Little Jawa Sep 1 '10 at 13:58

Wild shot: Do you have the new Ubuntu font beta installed?.

There are a couple of reports on the net that this font crashes Chrome: upstream bug, ubuntu bug.


I had something like this a very, very long time ago. I wonder where you're getting chromium from.

5.0.375.125~r53311 seems to be the latest official version (there is a slightly newer proposed version) but the current chromium-daily PPA is at 7.0.512.0.... I'm always slightlt dubious of people who suggest just blindly upgrading things but in this case it might help you get it working.

To install the PPA:

sudo add-apt-repository ppa:chromium-daily/ppa
sudo apt-get update

Then just install the updates. You'll get a lot of updates through this and it's quite likely you might find something breaks as this is bleeding-edge software.

If you find it doesn't work or something else breaks, you can go back to stock versions with ppa-purge:

sudo apt-get install ppa-purge
sudo ppa-purge chromium-browser
  • 3
    And remember: Just because it's the chromium-daily ppa, doesn't mean they don't offer stable, dev, and beta build of chromium, because they do! All are listed @ launchpad.net/~chromium-daily – aperson Sep 2 '10 at 1:09
  • Yup, good point. They are all different versions. -stable is only a couple of builds newer than the repo version, -beta is v6.* while -dev and -daily are v7.* – Oli Sep 2 '10 at 7:52

I am not sure what build you are running (beta, dev, daily or stable). The instructions I am providing you with will move you to the stable build.

sudo apt-get purge chromium-browser

This will purge Chromium. Now to remove other relate files

sudo rm /etc/apt/sources.list.d/chromium-daily-[build]-lucid.list /etc/apt/sources.list.d/chromium-daily-[build]-lucid.list.save

This removes the PPA for the build you are using. Replace [build] with the build you are using. Tab completion can help.

rm -rfv ~/.config/chromium/

This will remove the you Chromium settings.

sudo add-apt-repository ppa:chromium-daily/stable

This will ad the stable PPA.

sudo apt-get update

This will refresh the list of packages.

sudo apt-get install chromium-browser

This install the stable version Chromium. If this doesn't work try changing your theme. The terminal output mentions you theme.

  • I've done all this and even changed my theme but still nothing. What is that: segmentation fault? I remember using Chromium and it worked but suddenly is doesn't. I don't remember what I did as it stopped working few days ago and I was using firefox but it's just too slow in comparison to Chromium that's why I want it back. – freshnrg Sep 1 '10 at 19:59
  • You could try clearing you cache (~/.cache/chromium/). If doing all that doesn't work, try creating a new user (not a "Guest Session" it won't run do to a bug) and running Chromium via that user. A Segmentation Fault is caused by a memory violation. See en.wikipedia.org/wiki/Segmentation_fault – user415 Sep 1 '10 at 20:52
  • yeah it does work on new user account. but it's a bit pointless to creating it just for Chromium. will have to figure this out somehow. – freshnrg Sep 1 '10 at 22:30

Try launching it from the commandline: open a terminal (Applications->Accessories->Terminal) and type: chromium-browser.

If it launches, then you have a problem in your shortcut (very unlikely). You can edit it from System->Preferences->Main menu.

If it doesn't launch, you should get some error message displayed that should explain why it failed. If you can't fix it yourself based on that, please copy those messages to your original post, so that we can try helping you :)

In any case, you can try removing your local settings for it (under your HOME folder, delete the .config/chromium folder) so that it is restarted clean next time (as if you just installed it). Now be cautious: this will delete all your settings, including bookmarks...

To do that, under a terminal, type: rm -rf ~/.config/chromium

EDIT: the "Segmentation fault" is actually very interesting: it tells that Chromium crashed in an ugly fashion (not because of a handled error, but because it tried to do something wrong on the system). Either it is an issue with the installation, or with a plugin that you added to it... I think you should completely uninstall it, and reinstall it again, just to see if it solves the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.