I've installed Ubuntu 12.04.3 64-bit as a guest under VMplayer running on my Win7 host.

After Ubuntu installs, I launch and open a terminal.

I then enter the following:

sudo apt-get update
sudo apt-get install wine
sudo apt-get install xvfb
sudo apt-get install xfonts-100dpi xfonts-75dpi xfonts-scalable xfonts-cyrillic

When I launch xvfb, I get the following error:

“[dix] Could not init font path element /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType, removing from list!”

"x-ttcidfont-conf" should have been installed with "wine" as I got the same EULA when I install manually. However, it never gets recognized and when I check font folders, they're empty.

I've tried these steps as well:

  1. Alternate attempt 1:

    • sudo apt-get -y install x-ttcidfont-conf cabextract ttf-mscorefonts-installer
    • sudo dpkg-reconfigure x-ttcidfont-conf
  2. Alternate attempt 2:

    • Reset Ubuntu
    • At login screen: Press CtrlAltF1
    • Login
    • kill x server: sudo service lightdm stop
    • generate new xorg.conf file: sudo X -configure
      • This will create a 'xorg.conf.new' file in your current dir
    • return to GUI: sudo start lightdm
    • Login through UI
    • Open & edit xorg.conf.new and add the following two lines:

      FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

      FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

    • Save & exit
    • Logout of UI
    • At login screen: Press CtrlAltF1
    • Login
    • kill x server: sudo service lightdm stop
    • rename and move: sudo mv xorg.conf.new /etc/X11/xorg.conf
    • return to GUI: sudo start lightdm

I fully admit I'm a linux/ubuntu/xvfb noob...but I am good at Google searches and nothing seems to work.

What am I missing?

I've tried:

sudo apt-get -y install x-ttcidfont-conf
[sudo] password for <user>:
Reading package lists... Done
Building dependency tree
Reading state information... Done
x-ttcidfont-conf is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 17 not - upgraded.

and still get the same error message.

I've also tried:

  1. sudo apt-get upgrade
  2. Restarted ubuntu
  3. retried

Get same results. :-(

There is an in-house shell script that launches Xvfb followed by an application and apparently just hangs as a result. The first line in the shell script is:

Xvfb :2 &

And simply executing that command outside of the shell script causes the same error.

I've read in one of the many pages to help resolve this that I need an xorg.conf in a folder to point to font folders. I tried to create this and for the other fonts such as xfont-100dpi, xfont-75dpi, etc. there is content in the folders. Why am I not able to get any content in the equivalent font folder for x-ttcidfont-conf TrueType font?

  • Can you upgrade those packages with sudo apt-get upgrade then restart your session? – Braiam Sep 7 '13 at 1:11
  • Could you explain what is the adverse effect of that warning? What are you trying to accomplish installing that font? – Braiam Sep 7 '13 at 2:56
  • 1
    @gdaemon did you manage to solve it ? – vishal Oct 28 '13 at 21:09

You are missing the package x-ttcidfont-conf. A simple sudo apt-get -y install x-ttcidfont-conf should solve the problem.


I found that by executing the following command, I was able to resolve the problem:


Thanks for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.