240

I have an Android phone that connects with my computer via MTP. This works fine; I can see and transfer files with Nautilus. However, I often want to use the terminal to move large numbers of files, and I cannot seem to find the device anywhere in the filesystem tree. Nautilus reports the location as mtp://[usb:003,007]/, but it's not under /media or /mnt.

Does anyone know where it is?

12 Answers 12

185

As you have already found out, the mountpoints are in /run/user/$USER/gvfs/ (or /var/run/user/$UID/gvfs) and are named after the protocol, connection type and address they use. Which makes things more difficult, because the connection address may change every time you replug the device, even if it is the same port. If you have the same device twice it gets even worse.

You can use lsusb to display all connected USB devices from terminal:

$ lsusb | grep Google   # Note: This is a Nexus 4, change accordingly
Bus 002 Device 025: ID 18d1:4ee2 Google Inc.

As you have noticed Nautilus also gives this information via tool tip. You will find the encoded form of e.g. mtp://[usb:002,025] in /run/user/$USER/gvfs (or /var/run/user/$UID/gvfs) as mtp:host=%5Busb%3A002%2C025%5D


Asker's edit: This seems to require a newer version of libmtp and/or gvfs than is available per default in 13.04. Run sudo add-apt-repository ppa:langdalepl/gvfs-mtp and update before doing anything else.


Edit: PPA not needed anymore in saucy/13.10 and newer, filenames are listed in terminal as they are in Nautilus.

Edit 2016-01-11: I removed the script that was previously included in this answer due to lack of time for maintenance and improvements. You can still find it in the revision history.

| improve this answer | |
  • Thank you for your answer. Unfortunately, it doesn't work because the actual folder names (e.g. /DCIM/Camera/) are only visible in Nautilus, not the terminal. Thus, $Path/DCIM/Camera is not accessible with rsync. – bessman Sep 8 '13 at 14:16
  • 2
    The path is just an example and is different for Android phones. The phone must also be unlocked via lock screen to allow access to the data. – LiveWireBT Sep 8 '13 at 15:37
  • The path /DCIM/Camera/ exists on my phone, but in the terminal it is called /2404/2407/. That's the problem. If I cd into /2404/2407/ and run nautilus ., then /DCIM/Camera/ is opened. The phone is unlocked, otherwise I wouldn't be able to access it via Nautilus, right? – bessman Sep 8 '13 at 17:37
  • 7
    Note that in order for all of this to work, you need to have the gvfs-fuse package installed. Not all versions/flavors of Ubuntu have it by default (e.g. Ubuntu MATE 14.10 doesn't). Without it the MTP device won't get mounted as a local path and will only be usable by applications that support gvfs URIs. – user149408 Nov 7 '14 at 15:24
  • 2
    I found the gvfs/ directory eventually. However instead of $USER, the path on this PC is: /run/user/1000/gvfs/mtp:host=%5Busb%3A003%2C003%5D -- For others I suggest you just poke about, if you don't find it right away. – will Mar 3 '17 at 21:25
103

My Nexus device's memory can be accessed at:

/run/user/$UID/gvfs/mtp*

So if your $UID is 1000, you may find it by either doing

$ cd /run/user/$UID/gvfs/mtp*

or (for the exact location in an example assuming your UID is 1000),

$ cd /run/user/1000/gvfs/mtp\:host=%5Busb%3A001%2C006%5D/
| improve this answer | |
  • 2
    This should be the accepted answer since it doesn't not require installing any additional software. Thanks a lot user2529583! – NH. Jan 18 '17 at 0:45
  • Any idea if the mtp* filename can be renamed for use in Wine applications? Naive mv gives me mv: cannot move 'mtp:host=%5Busb%3A001%2C065%5D' to 'mtp': No such file or directory (note that the filename is tab-completed) – Mark Jeronimus Nov 10 '17 at 12:32
  • @Mark any character is a valid filename in linux. Look if there is a way rename it without mv. – Babken Vardanyan Nov 10 '17 at 12:35
  • Awesome. It works perfectly fine and saved me a lot of "trying out" on Raspbian Wheezy and Jessie – Zimano Dec 18 '17 at 10:15
  • 1
    Ubuntu 16.04 and Honor 9 Lite. After connecting phone /run/user/1000/gvfs folder is empty. – LRDPRDX Sep 15 '18 at 6:35
28

MTP mounted device usually can be found in : /run/user/1000/gvfs/


for eg if your Nautilus address bar shows mtp://[usb:001,006]/, then you can access by:

/run/user/1000/gvfs/mtp\:host=%5Busb%3A001%2C006%5D/

now on terminal you can copy files or folders:

  • cd into folder -> cd /run/user/1000/gvfs/mtp\:host=%5Busb%3A001%2C006%5D/
  • then copy required folders to current directory -> cp -r ~/videos/ .
| improve this answer | |
  • 3
    It works exactly like you say. But when I make 'ls -a' it is empty. – ycc_swe Sep 20 '17 at 16:12
12

I got an LG2 phone and I am running Xubuntu 15.10.

This is how I mounted the device to mnt directory in under my user.

  1. First make sure you have the following packages installed in your system.

    sudo apt-get install jmtpfs mtp-tools
    
  2. Connect your phone as MTP device and type the following command in your terminal.

    mtp-detect
    
  3. Uncomment user_allow_other in file /etc/fuse.conf.

  4. Create a directory mnt in your home directory.

    mkdir mnt
    
  5. Mount the device.

    jmtpfs ~/mnt
    
  6. Thats it. Now your device is mounted under the mnt directory created in step 4.

Note: There may be some steps that are unnecessary. But following the above steps worked for me.

Reference: https://wiki.archlinux.org/index.php/MTP

| improve this answer | |
11

This is working with:

  • Linux Mint 17.3
  • Samsung Galaxy S5

Try this:

  1. apt-get install mtpfs
  2. apt-get install mtp-tools
    • # yes could be one line (this is optional)
  3. sudo mkdir -p /media/mtp/phone
  4. sudo chmod 775 /media/mtp/phone
    • # Personally I'd restrict permissions to NO-eXecute
    • # At this point I'm not sure what is enough to mount.
  5. Unplug the phone micro-USB and plug-in, then...
  6. sudo mtpfs -o allow_other /media/mtp/phone
  7. ls -lt /media/mtp/phone

Output:

 total 0
 drwxrwxrwx 2 will will 0 Jan  1  1970 Card
 drwxrwxrwx 2 will will 0 Jan  1  1970 Phone
 drwxrwxrwx 2 will will 0 Jan  1  1970 Playlists
  1. ls -lt /media/mtp/phone/Card

Output:

 total 0
 drwxrwxrwx 2 will will 0 Jan  1  1970 Android
 drwxrwxrwx 2 will will 0 Jan  1  1970 DCIM
 drwxrwxrwx 2 will will 0 Jan  1  1970 LOST.DIR
 drwxrwxrwx 2 will will 0 Jan  1  1970 Music

Listing access to the SD-card on my Android phone. "Playlists" is a virtual directory called "/Playlists" which contains your playlists as .m3u files. (per man mtpfs)

That seems to do the trick. Useful commands to remember ...

  • sudo mtpfs -h ... lists the device's options. This seems to only work before you have mounted the device. So check first-off, perhaps.
  • mtp-detect ... shows lots of stuff about the device (part of mtp-tools).

Also, I think you need the phone/device "on", open the screen-saver if you have one so the device can connect.

I noticed that my USB-s mount as:

  • /media/will/usbdrive

So it might make more sense to mount under your username instead of the "mtp" stub. Also, review the post: "Mounting Your MTP Androids SD-card on Ubuntu", it has a few useful suggestions and extras.

References

I took my lead from these two posts:

| improve this answer | |
  • Hi although this works, I still find the MTP is too slow and often it is as if my Linux PC has locked. I support the further comments about using FTP. I did some digging and recommend the sshelper app. It is very useful, open sourced, and mature. Will work with Windows, Linux and Mac -- Or anything that supports SSH. Easy to use too. Give it a go. – will Sep 21 '17 at 7:54
10

Type mount. That will list every active filesystem.

| improve this answer | |
  • 16
    No, the device does not show up in the output. – LiveWireBT Sep 6 '13 at 22:54
  • 1
    Hmm. That sort of worked. I found it under /run/user/myusername/gvfs/. However, all the foldernames are just numbers instead of the actual names that I see in Nautilus. As such, it doesn't really solve my problem because I still can't easily use the terminal to move files to the device. – bessman Sep 7 '13 at 7:21
  • When Nautilus has the MTP device open, use the commands lsof -c nautilus | less to list all file files Nautilus has open. – waltinator Feb 3 '14 at 19:13
  • 1
    That solved it for me :) – marlar Apr 10 '15 at 10:28
9

I don't know exactly to traverse to MTP location via terminal. However, I found out that we can right click on the Internal storage / SD card and choose option "Open in Terminal". Doing so the location is directly opened in Terminal.

screenshot

| improve this answer | |
  • 3
    A real screenshot (of the internal framebuffer) would be so much better than a photo of the screen (with an external camera). – David Foerster Apr 19 '18 at 23:19
  • After finding that path, we can add the invariable part to the file manager left panel as a bookmark, for example /run/user/1000/gvfs. – cipricus Apr 10 at 14:42
6

This is not a direct answer to the problem, but a solution nonetheless.

After experiencing inconsistency's with USB connectivity, I bypassed the .gvfs and USB system all together.

I installed a simple ftp server on the android and voila! Connect to server (either ftp with login or without, depending on how you choose) from Nautilus/nemo/thunar and away you go.

Syncronisation of folders is handled through OwnCloud and/or BitTorrentSync.

And the FTP over wireless is way quicker than the USB connection was.

| improve this answer | |
5

MTP is a protocol, much like FTP or SSH. It fetches files when the user asks for it. Thus there is no mounted file system on the computer.

Use mtpfs in order to make it appear like a mounted file system.

mtpfs <a_folder_to_mount>

No need to specify the device. If you have only one device connected, then there is no ambiguity. I have not tested it with multiple devices connected to my computer.

| improve this answer | |
2

enter image description here

After accessing the correct path as said HERE and other answers, a good idea is to add the invariable path (for example /run/user/1000/gvfs) as a bookmark to the file manager left panel. When phone is disconnected, that folder will be empty.

I have noticed that there is a difference between the options available for a file accessed in this way and those available for the same file when accessed the "normal" way, by the mtp:// path (clicking "mtp" or the device name/numbers on the left panel): when accessed by /run/user/.../gvfs the file has in context menu ("Open with") all the expected options; these options are limited (reduced to default/vanilla ones) when the file is accessed by mtp://. Also, some programs (e.g. MKVToolNix) cannot access a file by the mtp:// path, but they can by the other one. This aspect may become important is some scenarios, like for example when one needs to create/download a file on the phone, process it through a computer program (e.g. MKVToolNix) and output it on an external device.

| improve this answer | |
1

I am able to manage files on a MTP connected Android device using gvfs-* commands (e.g. gvfs-cp, gvfs-move, ...) which are also mentioned in the following Wikipedia article: GVfs.

I wrote a simple CLI utility for file synchronization to/from an Android device: https://github.com/DusanMadar/PySyncDroid

| improve this answer | |
1

In the last few days, my MTP connection was deadly slow again. I'm still on 18.04 and can't upgrade to 20.04 just yet (I'm working on devices that require 18.04).

The first I encountered the problem, I was able to find a file with parenthesis and deleted that file and things went back to normal. Until now. I really need to have fast access to my pictures as I use that feature for my work, so I looked further... and found out that there is a fix available as expected in the launchpad bug report.

Here is a copy of the specific entry that fixed it for me:

I have just tried installing libmtp-1.1.17-2 on 18.04 from here: https://launchpad.net/ubuntu/+source/libmtp/1.1.17-2/+build/18694144 files:

  • libmtp-common_1.1.17-2_all.deb
  • libmtp-runtime_1.1.17-2_amd64.deb
  • libmtp9_1.1.17-2_amd64.deb
    (disconnect phone and after installation log out and log in back to the system or reboot for new libraries to be loaded)
    Now listing files is quick and I can actually transfer files.

The following are the commands I ran:

wget https://launchpad.net/ubuntu/+source/libmtp/1.1.17-2/+build/18694144/+files/libmtp-common_1.1.17-2_all.deb
wget https://launchpad.net/ubuntu/+source/libmtp/1.1.17-2/+build/18694144/+files/libmtp-runtime_1.1.17-2_amd64.deb
wget https://launchpad.net/ubuntu/+source/libmtp/1.1.17-2/+build/18694144/+files/libmtp9_1.1.17-2_amd64.deb
sudo dpkg -i libmtp9_1.1.17-2_amd64.deb libmtp-common_1.1.17-2_all.deb libmtp-runtime_1.1.17-2_amd64.deb

In my case, I had to reboot anyway, so I rebooted. But as the poster on launchpad said, you should at least log out and back in from your X11 session. I then took a few pictures, reconnected the phone as usual and it was instantaneously connected and worked as expected. No pause between the connection and the availability of the gvfs file system.

Note: The files are for Focal Fossa (20.04) but you can safely install them on Bionic Beaver (18.04) and it works. It would be great if they would make an upgrade to fix the problem in 18.04, though. Oh well...

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.