I tried to install Ubuntu Touch on my new Galaxy Nexus toro (which I bought today specifically for Ubuntu Touch). I followed the instructions I found at https://wiki.ubuntu.com/Touch/Install (installed all the packages, made android backup, unlocked the phone) until I accidentally executed

phablet-flash cdimage-touch -d grouper -b

instead of

phablet-flash cdimage-touch -b

It gave me this output:

igor@igor-Inspiron-N5110:~$ phablet-flash cdimage-touch -d grouper -b
INFO:phablet-flash:Device detected as grouper
INFO:phablet-flash:Download directory set to /home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1
INFO:phablet-flash:Download directory set to /home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1
INFO:urllib3.connectionpool:Starting new HTTP connection (1): cdimage.ubuntu.com
INFO:phablet-flash:Downloading http://cdimage.ubuntu.com/ubuntu-touch/daily-preinstalled/20130905.1/saucy-preinstalled-recovery-armel+grouper.img to /home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-recovery-armel+grouper.img
--2013-09-06 21:42:14--  http://cdimage.ubuntu.com/ubuntu-touch/daily-preinstalled/20130905.1/saucy-preinstalled-recovery-armel+grouper.img
Resolving cdimage.ubuntu.com (cdimage.ubuntu.com)..., 2001:67c:1360:8c01::20, 2001:67c:1360:8c01::21, ...
Connecting to cdimage.ubuntu.com (cdimage.ubuntu.com)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7344128 (7,0M) [application/octet-stream]
Saving to: ‘/home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-recovery-armel+grouper.img’

100%[======================================>] 7 344 128   1,73MB/s   in 4,6s   

2013-09-06 21:42:18 (1,53 MB/s) - ‘/home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-recovery-armel+grouper.img’ saved [7344128/7344128]

INFO:phablet-flash:Downloading http://cdimage.ubuntu.com/ubuntu-touch/daily-preinstalled/20130905.1/saucy-preinstalled-system-armel+grouper.img to /home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-system-armel+grouper.img
--2013-09-06 21:42:18--  http://cdimage.ubuntu.com/ubuntu-touch/daily-preinstalled/20130905.1/saucy-preinstalled-system-armel+grouper.img
Resolving cdimage.ubuntu.com (cdimage.ubuntu.com)..., 2001:67c:1360:8c01::1f, 2001:67c:1360:8c01::20, ...
Connecting to cdimage.ubuntu.com (cdimage.ubuntu.com)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 68095300 (65M) [application/octet-stream]
Saving to: ‘/home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-system-armel+grouper.img’

100%[======================================>] 68 095 300  2,07MB/s   in 32s    

2013-09-06 21:42:51 (2,02 MB/s) - ‘/home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-system-armel+grouper.img’ saved [68095300/68095300]

INFO:phablet-flash:Downloading http://cdimage.ubuntu.com/ubuntu-touch/daily-preinstalled/20130905.1/saucy-preinstalled-boot-armhf+grouper.img to /home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-boot-armhf+grouper.img
--2013-09-06 21:42:51--  http://cdimage.ubuntu.com/ubuntu-touch/daily-preinstalled/20130905.1/saucy-preinstalled-boot-armhf+grouper.img
Resolving cdimage.ubuntu.com (cdimage.ubuntu.com)..., 2001:67c:1360:8c01::21, 2001:67c:1360:8c01::1f, ...
Connecting to cdimage.ubuntu.com (cdimage.ubuntu.com)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7501824 (7,2M) [application/octet-stream]
Saving to: ‘/home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-boot-armhf+grouper.img’

100%[======================================>] 7 501 824   1,74MB/s   in 4,5s   

2013-09-06 21:42:56 (1,58 MB/s) - ‘/home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-boot-armhf+grouper.img’ saved [7501824/7501824]

INFO:phablet-flash:Restarting device... wait
INFO:phablet-flash:Restarting device... wait complete
WARNING:phablet-flash:Device needs to be unlocked for the following to work
INFO:phablet-flash:Flashing system to /home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-system-armel+grouper.img
< waiting for device >
erasing 'system'...
OKAY [  0.044s]
sending 'system' (66499 KB)...
OKAY [  7.697s]
writing 'system'...
OKAY [  5.756s]
finished. total time: 13.496s
INFO:phablet-flash:Flashing boot to /home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-boot-armhf+grouper.img
sending 'boot' (7326 KB)...
OKAY [  0.859s]
writing 'boot'...
OKAY [  0.443s]
finished. total time: 1.302s
INFO:phablet-flash:Flashing recovery to /home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-recovery-armel+grouper.img
sending 'recovery' (7172 KB)...
OKAY [  0.836s]
writing 'recovery'...
OKAY [  0.458s]
finished. total time: 1.295s
INFO:phablet-flash:Booting /home/igor/Downloads/phablet-flash/ubuntu-touch/20130905.1/saucy-preinstalled-recovery-armel+grouper.img
downloading 'boot.img'...
OKAY [  0.828s]
OKAY [  0.399s]
finished. total time: 1.227s
INFO:phablet-flash:Clearing /data and /cache
error: device not found
ERROR:phablet-flash:Command 'adb shell mount /data' returned
non-zero exit status 255

After that, it rebooted the phone, and it the only thing it showed me was a black screen with a picture of a lock and the word "Google" in the middle. The phone did not reacted on pressing any buttons, including the power button. adb didn't see the device:

~ $ adb devices
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached 

~ $ 

, which prevented me from restoring android as it described at https://wiki.ubuntu.com/Touch/Install. I tried to reboot it by holding power button, it didn't help. Than I rebooted by unplugging the battery. After that, I tried to boot in recovery mode, but it only showed me aforementioned black screen. adb still doesn't see the device.

What can I do now? Where else can I seek for help?

  • There is a message that says WARNING:phablet-flash:Device needs to be unlocked for the following to work did you unblocked the device as said in the instructions? – Braiam Sep 6 '13 at 20:01
  • Yes, I believe I did. At least, I followed all the instructions, that should have unlocked it. I did not check the result later, though. – igr Sep 6 '13 at 20:36
  • Can you try to unlock it as the instructions suggest again? If it doesn't work, I think you should go into live chat and use this information as starting point. – Braiam Sep 6 '13 at 20:45
  • No luck :-( It is just "waiting for device". sudo fastboot devices shows nothing. I'll try that live chat tomorrow. Thanks for your help! – igr Sep 6 '13 at 20:54
  • Any update on this issue? – Braiam Sep 19 '13 at 18:20

Revert to factory / Android setup.


Look for: 'Restoring Android'

You will need to put phone into 'Recovery Mode' for this to work.

UPDATE (further details)

Note: I have only had to try this for a Nexus 7 (tablet), as I have several (2nd hand) and have nearly bricked three of them. I have yet to try with a Nexus 4 (don't have one) or Nexus 10 (more expensive).

You can usually (with difficulty) still get device into 'Recovery Screen'.

  • Power-off (fully powered down) for at least ten seconds.

  • Hold 'Power' + 'Volume-Up' (varies between devices/Android version) for only 2-4 seconds.

( This may take several attempts. )

  • Then you should be able to re-flash, to Google/Android factory.
  • His phone is locked, and adb don't detect the devices. – Braiam Sep 6 '13 at 23:30
  • I have had this same issue with a Nexus 7. I could (with difficulty) still get to 'Recovery Screen'. Ten seconds fully powered off; hold power + vol-up (varies between devices) for 2-4 seconds; several attempts; etc. Then I was able to re-flash to Google/Android factory. – david6 Sep 6 '13 at 23:45
  • Could you add that as your answer instead. We look into detailed procedures to answer questions. – Braiam Sep 6 '13 at 23:47
  • I tried your method about ten times, no luck :-( How did you know that you should hold 'Power' + 'Volume-Up'? Maybe the combination is different for Galaxy Nexus? – igr Sep 7 '13 at 6:25
  • 2
    It works! Windows machine and this guide did their job. Thank you again, David, your advices really helped! Could you edit your answer so I could accept it, for future generations? – igr Sep 9 '13 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.