146
Gtk-Message: Failed to load module "canberra-gtk-module"

but I already have the libcanberra-gtk-module and libcanberra-gtk3-module installed. (i.e. I tried this solution, but it is already installed.)

This happens for instance, when I run ipython --pylab

I'm running Ubuntu 13.04 - raring.

166

install gtk and gtk3 module should solve it.

sudo apt install libcanberra-gtk-module libcanberra-gtk3-module
  • 39
    For me sudo apt-get install libcanberra-gtk-module worked fine – NZD Mar 3 '17 at 1:54
  • 4
    This should be the accepted answer – Brij Raj Kishore May 26 '18 at 2:05
  • This works for Android Studio – Gabor May 30 '18 at 18:56
  • 7
    This worked for me on Ubuntu 18 – Guus Jul 3 '18 at 15:40
  • worked for me too, ubuntu 18.04.1. Installing pidgin from terminal was the only way to show office-communicator protocol (for Lync) and I stumbled on this same problem but solved with the above and now OCommunicator shows. Thanks! – Yannis Dran Nov 12 '18 at 17:27
94

This problem may occur on a 64-bit machine when one installs 32-bit software that requires canberra-gtk-module. acroread, for example, can cause this problem. In this case, the solution is to install the 32-bit version:

sudo apt-get install libcanberra-gtk-module:i386

One should leave the 64-bit version as well as it is necessary for 64-bit programs which attempt to use it.

  • I have a 32-bit system so I don't think this applies. Any other ideas? It's the Copy.com client that throws the error. – endolith Oct 21 '14 at 1:22
  • It fixed my 32-bits Firefox on Ubuntu 64-bits. – Dielson Sales Dec 15 '14 at 17:27
  • 8
    This did not help for me. I also tried sudo apt-get remove libcanberra-gtk-module before sudo apt-get install libcanberra-gtk-module:i386, still does not work. – Mads Skjern Jun 18 '15 at 11:23
  • 4
    Doesn't work for me. – dspacejs Nov 15 '15 at 11:05
  • 1
    Did not solve this error with Polar Bookshelf on Ubuntu 18.04 – SteveSong Oct 20 '18 at 11:11
17

I had the same problem and solve it with the solution given in this launchpad issue.

sudo apt-get install --reinstall libcanberra-gtk-module
  • Didn't work for me. – Dan H Aug 9 '16 at 20:36
  • 2
    WARNING: User Paparazio reported that this command removed a lot more software than he was expecting. See his question for details. – wjandrea Jun 8 '17 at 20:29
  • Didn't work for me – Jeff Davenport Oct 15 '18 at 17:55
0

Maybe too much but this solved my problem:

$ sudo apt-get install libcanberra-gtk*
  • 4
    terrible idea and didn't even get rid of that error when I tried it. – tatsu Mar 3 '18 at 18:36
  • 3
    Please, use apt-get with wildcards with caution - or better: don't use wildcards. This often leads to unexpected results that are not easy to fix for people without in-depth experience of the package management system. – byteborg Mar 1 at 12:03

protected by Community Jul 20 '17 at 8:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.