I am completely new and have never even used terminal before, let alone try install a driver, so while I’ve read countless answers in response to the above problem, I don't even understand when I should press 'enter' in terminal.

My situation is I bought a new Toshiba Satellite C850- F0155 with no OS. Installed Ubuntu 12.04 from a CD. But only way to connect to net is through ethernet cable (i.e. no wireless option). The wireless card is a Realtek RTL8188CE. My Kernal is 3.2.0-52-generic.

I downloaded rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013(1).tar.bz2. I attempted to follow the instructions in the read me file, but i don't for the life of me understand them, nor any others in forums i've poured over.

If there is a kind soul who could help me with step by step (à la idiots guide) I would be deeply deeply greatful.

P.S. I have emailed Realtek with my query but was just sent the same read me file I couldn't understand to begin with.

  • 1
    Do you still need help? I maintain a forked version of the driver that fixes the compile errors you'll likely encounter, especially as you upgrade. It can be found here: github.com/FreedomBen/rtl8188ce-linux-driver I can help you if you are still struggling. – Freedom_Ben Nov 29 '13 at 23:49
  • @Freedom_Ben Thanks for this driver! I was able to properly compile the driver. It also indicates I am connected to the wifi-network. However, I seem to be unable to actually transfer data. I am using Ubuntu 13.10 (even though verify_branch.sh asks me to switch to fedora-20). Additional info is that, originally, I had "rtl_pci" and "rtl8192c_common" from lsmod, but I seem unable to restart those (FATAL module not found). Do you have any suggestions on how to fix this issue? (I tried with both the fedora-20 and ubuntu-13.10 branch) – Bernhard Feb 25 '14 at 12:42
  • @Freedom_Ben I posted a new question over here: askubuntu.com/questions/426042/… – Bernhard Feb 25 '14 at 13:30

The driver you're looking for is no longer maintained by RealTek, so I've put it up on GitHub where I maintain it from version to version so that it compiles and works. So far, I as well as several others have had good experience using this driver. You can find the driver here on Github: https://github.com/FreedomBen/rtl8188ce-linux-driver

There are full instructions located on the project page (that link will take you there) and also in the README.md file that comes with the checkout.

The commands you see in the instructions should be entered into a terminal prompt, and enter should be pressed at the end of each line.

Please let me know of any issues you encounter and I'll try to help.

  1. Move the file you downloaded to your home directory using your file manager or terminal

     mv [destination of downloaded file]  /home/[username] 
  2. Now we move to our home directory and Unzip the file using the following command or right click and select Extract here:

     cd /home/user 

    tar xvjf  rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013(1).tar.bz2 
  3. Now access the Directory which we extracted

    cd rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013(1) 
  4. Next we install the necessary dependencies to compile the driver

    sudo apt-get install gcc build-essential linux-headers-generic linux-headers-$(uname -r)

  5. Now we start the compilation

  6. and then sudo make install

  7. Execute modprobe rtl8192ce

  8. Now If all went right your system should be running the wireless driver,Now we need to tell the system to load it whenever it starts, so we will edit the file /etc/modules

    sudo nano /etc/modules

The file initially will look like this

enter image description here

we add the line rtl8192ce to it and it will look like this

enter image description here

Press ctr+O to save it and ctr+X to exit nano editor

There seems to be a bug in the manufacturers driver and in case you are not able to compile it please read this. See the NOTES in the link.


  • Hmm, the last links in your post are broken. I am using 13.10. Would these guidelines still help me? – Bernhard Feb 25 '14 at 10:50
  • It should work. – Stormvirux Feb 25 '14 at 11:07
  • 2
    I get a 404 error on both links? – Bernhard Feb 25 '14 at 11:22

The driver for your device comes with ubuntu when it is installed but it can be problematic.

Please do:

echo 'options rtl8192ce swenc=1' | sudo tee /etc/modprobe.d/rtl8192ce.conf  
sudo modprobe -rfv rtl8192ce
sudo modprobe -v rtl8192ce 

protected by Community Feb 12 '14 at 9:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.