4

I'm in Ubuntu 12.04. I'm already logged in to an Ubuntu One account. I'm trying to install software from the Ubuntu software center. It's asking me for my Ubuntu One login, and then rejecting it. (It does work to log me in to Ubuntu One on this computer, an Android phone, and a Windows 7 computer.) I've tried resetting my password via a "reset password" email link: I get a message that I'm unauthenticated. I've tried cutting and pasting the login code sent via email: the code is not recognized. I've tried creating a new account -- something I don't really want to do -- it tells me an account already exists for my email address. Help?

2

I just had this problem when trying to install the "snap" version of vlc.

I have several machines running 16.04 "Xenial" and on the ones I have tried, when I try to install the snap version of vlc (labeled "nonfree") in the Ubuntu Software utility, the utility puts up a dialog asking for my Ubuntu One email address and password. I have tried numerous times, but the dialog will not accept any of the registered combinations. I used the button on the dialog to reset my password, and the software still does not accept the new password. I confirmed that I am still able to log into the Ubuntu One SSO sites using the new password.

Here's a workaround -- open up a terminal and you can install a snap package using the command line utilities -- no Ubuntu One password requested.

$ snap find vlc
Name  Version  Developer  Notes  Summary
vlc   daily    videolan   -      The ultimate media player

$ snap list
No snaps are installed yet. Try "snap install hello-world".

$ sudo snap install vlc
[sudo] password for you:
110.10 MB / 110.10 MB [==================================] 100.00 % 708.43 KB/s 

vlc (stable) daily from 'videolan' installed

You may find that the application doesn't appear in the Ubuntu dock, but if you search for it, open it, and pin it to the dock, it will stay.

You may also find that the Ubuntu Software utility is confused about whether the application is installed -- I found even when I used Synaptic to make sure I got all the pieces of the "regular" vlc removed, Ubuntu Software now shows BOTH installed.

0

It seems like you might have two separate problems--a problem logging into the Software Center, and a problem resetting your Ubuntu One password. This is not necessarily what's happening, but I think it's worth checking to make sure.

Installing software in the Software Center does not ordinarily require your Ubuntu One password. Instead, it usually requires your local user account password. Assuming you haven't changed your user account password (changing the Ubuntu One password doesn't change it), this is the password you set up when you installed Ubuntu originally.

Furthermore, even if you have to enter your Ubuntu One password (for example, to access a software source for software you paid for or wish to pay for), you might still also have to enter your local user account password. It might be prompting your with multiple password prompts. A bug could perhaps even cause them to appear in the wrong order.

If you don't remember your password or it isn't working (and you're typing it in correctly, Caps Lock is not on, and you're not accidentally using the wrong keyboard layout), then you can reset it:

Note that this is totally different from resetting your Ubuntu One password. This doesn't even involve accessing the Internet (except in the sense that those instructions are on the Internet).

If that doesn't help, please edit your question with more details, including what software you're attempting to install, exactly what you're doing in the Software Center, and exactly what happens, including the complete and exact text of the error message that told you your login was not accepted.

If you're installing paid software and you have to enter a special password to access the online software source, please edit your question to indicate that, and to provide as many details as possible.

If using your Ubuntu account password as described above does enable you to install software in the Software Center, then I recommend posting a separate question about the Ubuntu One problem (as then it is definitely a separate issue).

0

It is clear he is trying to install "nonfree" software, which is not necessarily paid (e.g. fragment was $0.00 during its time in the store, seems to be gone in 16.04).

I am currently having similar trouble with the new snap for Krita, requires Ubuntu One login through the software center that fails, but it works on the Ubuntu One site. This does not something that the OP can do something about on his own.

My suggested course of action is to file a bug report. Here is a good place: https://launchpad.net/ubuntu/+bugs. I am aware the question is old and the problem is not new, but it does not seem to have been solved.

  • 3
    nonfree doesn't mean "free" in the price sense BTW. It means distribution is prohibited and the software is highly restricted. – TheWanderer Aug 28 '16 at 14:20

protected by Community Dec 27 '16 at 22:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.