2

When I plug in my MS LifeChat LX-3000 headphones into my usb drive into Dell Inspiron, I have to manually change the sound output to the headset. The sound will sometimes automatically transfer from the speakers to the headset, and sometimes it will not. If I leave the headphones plugged in and even have changed the output the headset, when I wake the computer from a suspend session, I do not have volume control. Sound will still be coming from the headset, but when I change volume from my keyboard the volume remains the same. When I change the output to the speakers again, I have full control.

Is there a fix for this? Is there a setting or a configuration file I can change? Is this a known bug?

2

Okay. I've discovered the answer to my question on another thread. For pulseaudio >= 0, you have to add the line below to /etc/pulse/default.pa to configure pulseaudio to change audio source on connect.

load-module module-switch-on-connect

After you add this line in, make sure to restart pulseaudio with:

pulseaudio -k

The thread I found the answer on: Unable to make sound play in headset

  • Confirmed that this works on Ubuntu 14.04 as well. Both the microphone and headphone parts of the LX-3000 are switched on connect. – jmiserez Sep 9 '14 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.