8

I have installed a Windows 7 as virtualbox-guest. My Ubuntu works as host. The sound is stuttering ugly. I tried to change that by changing the Audio-Controller to ICH AC97 and install the driver downloaded from CHIP. Result: After a restart nothing has changed, Sound stutters like before. Is there a way to get a proper sound? The Guest additions are installed and are working fine.

This is the Ubuntu HOST: Screenshot of System information

These are the settings of the virtualbox-machine:

Win7, 64bit

Mainboard settings

Processor settings

Acceleration settings

Audio settings

  • Did you try with Virutalbox guest addtions? – dedunumax Sep 5 '13 at 17:59
  • guest additions are installed. – zulu34sx Sep 5 '13 at 19:26
  • 1
    Please add details on your VM settings (processor cores, RAM assigned, virtualization settings VT-x/AMD-V, host audio driver used) with an edit to your question. Hardware specs of your host may also help to see further. – Takkat Sep 5 '13 at 20:32
  • thank you. I added some information. If you need any further information, i'll add them to the question, too. Just ask, please. – zulu34sx Sep 6 '13 at 8:19
  • 3
    Great, I had the problem since years. I put the execution cap to 100% and almost everything was fine (90%). I still used Intel HD Audio driver in the guest (Windows 7) and PulseAudio in the host (Ubuntu 13.10). Then I changed the host driver to Alsa-Audio-Driver and it seems that the last 10% of problem is gone, too. Thanks a lot, guys. Gerhard Hanau/Germany – user259608 Mar 18 '14 at 18:30
7

Having experienced the same Windows guest stutter under an Unbuntu host (12.04) - except in Win 8.1 - I found a solution that mostly conforms with Takkat's answer. My stutter occurred with the Windows guest being allocated 4 out of 4 cores, but the execution capped at 75%, with 4GB RAM, and 256 MG graphics RAM. Switching to 2 out of 4 cores - but removing the execution cap - running at 100%, eliminated 90% of the stuttering. But not all of it.

The final 10% - and the total elimination of stuttering - came when I switched from the default PulseAudio driver in VirtualBox Manager's settings, to the ALSA Audio Driver. Please note, prior to the aforementioned reallocation of CPU's and execution caps, I had also tried this driver change, and it did not remotely eliminate the stutter. The two changes in combination was required.

5

Stuttering audio almost always indicates an insufficient performance of hardware, or memory. This also depends much on the audio source, and the software used.

In case you have no sound issues on your host Ubuntu different Pulse Audio settings will not do much about sound issues arising from running a quite demanding guest OS like Windows 7.

To minimize effects coming from limitations of a virtual machine we therefore have to make sure to assign as much hardware ressources to the guest OS as possible, but make sure the host OS is still able to perform well (including Pulse Audio in your case!).

From what we can see from your settings it seems that the requirements to get a smooth audio experience are met. There are few things only we may try to see whether there is an improvement:

  • assign 2 of 3 CPU cores without an execution cap (or 3 of 3 but then with an execution cap)
  • give the guest OS more RAM (e.g. 3 GB of 4 GB)
  • assign 256 MB of graphics RAM.

In case we then have a better sound output we may reduce the ressources step by step to find the optimum setting for the software we run on our guest.

If we still cant get sound output smoothly we may have to try using a software with less demanding sound processing like e.g. WinAmp or Foobar2000 to further track the issue down.

It may however be that your hardware capabilities - even though quite good - still are inssufficient for running Windows 7 and your additional software to play sound (and video?) at the same time.

  • 1
    i had this problem with an XP-guest, too. But to get rid of the problem i'll try your approach. Thanks for the effort. A software less demanding is quite impossible; even the turn-on-sound of windows itself is sloppy. I'll try and let you know soon, thank you! – zulu34sx Sep 6 '13 at 13:37
  • 3
    I tried configurations with all 3 cores,one core, much rum, almost no ram. result: Performance of host and guest alter as expected, the stuttering is always exactly the same. Any other CPU-/BIOS- or other changes than might help? – zulu34sx Sep 6 '13 at 13:54
  • 2
    Sorry but you're theory about performance and hardware is wrong. First off sound is the least performance intensive element of the OS. Second, I am getting this issue on an arch host running with an i7 6700k 4.2Ghz, a GTX 1080 and 32Gb of RAM (with 2 to 6 threads allocated, 128mb-256mb vram, with without 2D/3D accel, ALSA PULSE, 6 to 20GB of RAM). It is not resource based. This issue repeats across Win 7 to 10 guests for me (any OS that uses Intel HD Audio codec), no issues with ALC97 but that codec only works with XP. It's an issue wiith the VBOX codec and they've been having it since 2006. – thebunnyrules Feb 5 '17 at 19:13
5

in Virtual Machine Settings/Audio I changed Host Audio Driver from ALSA Audio Driver -> to PulseAudio and sound became fine. No other changes to configuration (VirtualBox Guest Additions 4.3.12 (CentOS 6.5), by the way)

  • Could you please also share your other settings (number of cores, execution cap etc) that provided you fine sound (because those seems to affect it too) ? Thanks a lot in advance – Yuriy Nakonechnyy Dec 21 '15 at 14:49
2

This happened to meet too, for some reason the CPUs were on 4 of 8. I use a Macbook Pro running OS X 10 and Windows 7 using VBox. When I put the CPUs down to 1 it started working much better. check it out.

1

I have windows 7 guest, Debian host, and had no sound.

MSI board, AMD CPU, Xonar sound card, onboard sound turned off in BIOS

Debian host showed OXYGEN chipset, which is what Xonar uses.
No audio device showed in guest.

Here is what I did to get sound:

  • Added the RealTek AC97 audio driver from their website for windows 7 64-bit, paying attention to where it downloaded to.
  • Go to device manager > Audio > Driver, manually change the driver, point it to the folder and tell it to include subfolders.
  • should install fine except for the windows warning - ignore it, Realtek is legitimate.
  • Then I had audio from the Xonar, but it still stuttered. So, went to machine audio settings for the guest, changed it from AC97 to Intel HD Audio.

NOW it works and sounds excellent.

NOTE: Key to this fix is the RealTek driver. Some people had to switch to Alsa from Pulse Audio. Mine works fine WITH pulse audio. This probably has to do with how the HOST machine is set up.

I got NO sound unless I used the 537 realtek driver. others have used the 536 I did not try the 536.

  • Would you consider adding more information that can clarify how you achieved this result? A set of steps someone can follow, if they want to replicate your answer :) – ThatGuy Nov 17 '16 at 1:20
1

I have Linux Mint 17.2 host and Win 7 Guest and also had problems with sound. I didn't change default sound properties in VirtualBox:

Host Driver: PulseAudio
Controller: ICH AC97

Installing virtualbox guest additions didn't help to recover sound. Then I downloaded and installed Realtek AC97 Driver from realtek.com.tw on guest machine and sounds works now with PulseAudio and Alsa Driver as host driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.