0

I will start this thread like most of people.

I am new guy in Ubuntu. I have tried to make right installation but always getting some problems. I have laptop HP Pavilion g7 1153er. This laptop equipped with ATI Radeon HD 6470M and i5 2410M CPU so I have hybrid graphic with Intel hd video 3000. I have took this laptop with Windows.

But I am working with web-services and developement a lot so would like change my OS to Ubuntu. I have started with Ubuntu 12.04 and got that my system doesnt want to start up without additional parameter nomodeset. I have used it, install OS and thought that problem is with radeon. So I have installed (from 7 time reinstalled OS) driver from amd site. But this isn't help. When I checked my logs I see that main problem is with intel video.


Fatal server error:

[ 18.145] atiddxProbe: fail to probe intel VGA device

[ 18.145] (EE)

Please consult the The X.Org Foundation support

for help.

[ 18.145] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.

[ 18.146] (EE)


I checked intel drivers and saw that they are adapted to Ubuntu 13.04 now. So I have tried few times install them to Ubuntu 12.04 and failed. To move further I have installed Ubuntu 13.04. This system required two additional boot parameters to work: acpi=off and nomodeset. I have installed and seen that it works with slow screen processing. Than I installed Intel driver and this helped to me remove acpi=off from boot string.

I have digged a lot of info to check all this things like a new user. I know that experience it is great but I am trying to solve this problem third day and my work is stopped. Do not want to switch back

So could any body help me to find solution for video processing speed. I still thinking that problem is with drivers. What is the best in my situation? And do I need to use nomodest for each start up?

Please help me with this problem or post some links for similar problem. I have checked many posts but problems was little bit different.

Sorry for my english and thanks.

Maybe this will help.

uname -a

Linux w-HP-Pavilion-g7 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

lspci -k | grep VGA -A2

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    Subsystem: Hewlett-Packard Company Device 1672
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
--
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Seymour [Radeon HD 6400M/7400M Series]
    Subsystem: Hewlett-Packard Company Device 1672
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

I have move further and tried to install amd driver .... thought it will help. After generation of xorg.config and reboot I have got again error in xorg

atiddxProbe: fail to probe intel VGA device

after revert xorg.config to backup I was able to start ubuntu but the desktop was empty. I have tried to start unity but got another

error compiz (core) - Error: Plugin 'opengl' not loaded.

Completely confused

.......

Continuing searching solution. Tried installed drivers few more time with different instructions for 13.04 and 12.04 as well. I have seen some statistic that each time when I am generating xorg.conf after radeon drivers preparation I get graphic error about Intel adapter (Please check this error examples above, they are the same). And when I completely remove xorg.conf or choose back to default setting (make the same: remove xorg.conf) than everything works again. All this time use nomodeset for Ubuntu start up, without it getting black screen.

Searching solution at few forums but havent got any suggestion. I have feeling that it is impossible to fix this problem. :)

1

I have posted one forum and I have got reply with suggestion to try "acpi_backlight=vendor" option for grub. This helped a lot. With using acpi_backlight=vendor option without nomodest I have seen right graphics for ubuntu 12.04 but havent set hybrid graphics there right.

Than I have tried to do the same with Ubuntu 13.04. And made:

1) “acpi_backlight=vendor” option in start line for installation Ubuntu 13.04

2) after installing OS all grub options left configurated in grub. So I have installed intel driver than(https://01.org/linuxgraphics/downloads)

3) checked grub configuration,

 $ sudo gedit /etc/default/grub

keeped “acpi_backlight=vendor”, and removed “nomodeset” from there and got GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

saved config file and updated grub

$ sudo update-grub

4) installed ati catalyst according to http://wiki.cchtml.com/index.php/Ubuntu_Raring_Installation_Guide#Installing_Proprietary_Drivers_a.k.a._Catalyst.2Ffglrx

And after this steps I have got all my problems solved

The main reason of atiddxProbe: fail to probe intel VGA device was using of “nomodeset” at grub for boot without black screen but “acpi_backlight=vendor” helped a lot.

1

I have a Pavilion g6 1364sl with Radeon HD7450M. Ubuntu 13.04.

I try to upgrade from xorg-xserver-video-ati to fglrx (non-free) via control panel.

Next reboot unity crash and panels disappear. I've done thousand tricks, including download driver from ati site. Nothing! Some module were still crashing unity.

Rollbacked all, I try:

keeped “acpi_backlight=vendor”, and removed “nomodeset” from there and got GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

saved config file and updated grub

and everything is ok !!!! Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.