Just installed Ubuntu Server 12.04 on my laptop. The desktop version always had driver issues but only with WiFi not the ethernet, and I could just hard wire and install the proprietary drivers manually and it would work. But on my installed server I get no Ethernet connectivity.

ifconfig only shows lo for loopback an not eth0 like usual.

lshw -C network

*-network DISABLED
   description: Ethernet interface

I tried

ifconfig up

up: error fetching interface information: device unknown



showed that by b34 and b44 modules are there but they were showing 0 in the column for in USE and no programs were using them, but b44 was using another program.



lspci -nnk | grep -i -A2 net

05:00.0 Network Controller 0280 Broadcom Corporation, BCM4311 802.11B/G WLAN 14E4:4311 REV 01
Subsystem: Dell Wireless 1390WLAN mini card 102b:007
Kernel driver in use b43-pic-brige
Kernel module: ssb

08:00.0 Ethernet Controller 0200 Broadcom Corporation, BCM4401-B0 100BASE-TX 14E4:170C REV 02
Subsystem Dell Device 102B01f5
Kernel driver in use b44

thank you.

  • 1
    Please add the output of lspci -nnk | grep -i -A2 net to your post.
    – Oli
    Sep 5, 2013 at 11:27

2 Answers 2


I was able to fix this by doing:

sudo ifconfig wlan0 up

Perhaps that'll help.

  • 1
    Thank you! I actually ended up doing this awhile back but because I was in school I didn't come around to update it. I cant 1 Up but I would if I had the rep. It was my eth0 card i was trying to start up though so I used eth0 instead of wlan0. Sep 13, 2014 at 0:52
  • 2
    I ran iwconfig to grab the interface name then sudo ifconfig enp0s31f6 up
    – Natim
    Jan 26, 2018 at 9:20
  • Followed this article, worked like a dream - linuxbabe.com/ubuntu/… Nov 11, 2019 at 12:18
  • 1
    ifconfig was not available but ip was. I did sudo ip link set eth0 up, and sudo dhclient eth0. You can find the interface names with ip a, and potential renames (from e.g. eth0) with dmesg | grep eth0.
    – wjakobw
    Nov 2, 2020 at 19:39
  • @Natim iwconfig shows wifi, but your enp.. seems like ethernet. So do not get confused..
    – Timo
    Apr 24, 2021 at 14:00

Is your b44 controller blacklisted in a file under /etc/modprobe.d ?
If yes, does removing the lines in this file (or maybe the whole file) help?
I followed an advice to question 308958, and removed the whole bcmwl-kernel-source, which didn't complete cleanly (probably because a the chicken and egg issue that I did not have connectivity).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .