0

I have 2 samsung 840s in my computer, one boot and the other expanded storage but Ubuntu recognizes the second as a removable drive but I want them both to be recognised as internal drives, how do I get it to mount as an internal drive?

  • I used Gparted and have them both ext4 and primary – raincolt Sep 5 '13 at 8:36
  • 2
    Just add second drive's partition info inside your /etc/fstab. You can achieve it's UUID running blkid or ls -l /dev/disk/by-uuid. – Danatela Sep 5 '13 at 8:50
  • What do you mean it recognizes the second as removable? – psusi Sep 5 '13 at 14:47
2

You have to enter your 2nd hard disk information to /etc/fstab file. Then your 2nd hard disk will be treated by internal hard drive.

Just go for following step:

  • First take back up of /etc/fstab and unmount all 2nd HDD partitions

    sudo cp /etc/fstab /etc/fstab.backup
    sudo umount /dev/sdb*
    
  • Execute following command to get your 2nd HDD UUID information that will help you to configure /etc/fstab file.

    sudo blkid
    

    Search for your 2nd hard disk UUID of all partitions. Your 2nd HDD partitions shouls be displayed like: /dev/sdb1: LABEL="Backup" UUID="00A0CE7EA0CE7A24" TYPE="ntfs" and so on. It is just an example but format will be same.

  • Now copy the UUID of the partitions of 2nd HDD which you want to insert in /etc/fstab file.

  • Now open /etc/fstab file and insert entry for your HDD partitions on the last line of /etc/fstab file. Take help from previous entry, for format etc:

    sudo gedit /etc/fstab
    

    When opened your entry would be like this:

    UUID=<your_UUID_for_2nd HDD partitions> /media/<location_where_you_want_to_mount>             ntfs    errors=remount-ro 0
    

    Just an example:

    UUID=00A0CE7EA0CE7A24 /media/Backup ntfs errors=remount-ro 0

  • Now create location where to mount your 2nd HDD partitions. Create a folder for each partitions to mount. For example:

    sudo mkdir /media/Backup
    
  • Then execute this command once finished:

    sudo mount -a
    

You can refer this link for further help: Auto mounting with /etc/fstab Hope it works for you..

| improve this answer | |
  • Just a note: /media is the system managed path for auto-mounted drives. I'd better mount my drives under old point, /mnt. – Danatela Sep 5 '13 at 9:17
  • I don't think so, it effects something. It is fairly a convention used by latest versions of Ubuntu. or you can mount any where you want. for example in your home directory. – Saurav Kumar Sep 5 '13 at 9:21
  • SSD's need the discard,noatime options too – user107425 Sep 5 '13 at 9:22
  • 1
    This doesn't make it "treated as internal", it makes it mount automatically at boot instead of when you first click on it in the gui. Having it mounted under /media makes the gui show the icon. – psusi Sep 5 '13 at 14:50
  • Does it make any difference.. It will make it as internal also.. Do you bet me? – Saurav Kumar Sep 5 '13 at 15:18
0

For anyone using Ubuntu 16.04 and wanting to do this with a GUI, I found an easy way. (I presume it would be similar for other versions of Ubuntu, but I haven't tested)

  1. Start the 'disks' utility.
  2. Select your disk
  3. Click gears
  4. Select 'Edit mount options...'
  5. Set to manual, if not already
  6. Untick "Show in user interface"

(You can also set the mount point in this dialog)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.