Why does the mouse cursor disappear on the desktop in Unity or GNOME under 13.04 running in a Virtual Machine (VMware Fusion on a Mac in my case)?

All I did was upgrade to 13.04 ... I've been using Ubuntu for a number of years (and VMware Fusion) and I've never seen such a persistent problem.

I tried :

  • Reinstalling VMware Tools
  • gnome-tweak-tool
  • unity-tweak-tool
  • Creating a new userid
  • Loading Kubuntu desktop
  • dpkg-reconfigure xorg and dpkg-reconfigure xserver-xorg

Nothing worked.

  • 1
    Please don't write the answer into the question! You are able to create a new answer and post the content there. – Lucio Sep 4 '13 at 22:03

Solution written by OP inside the question:

Finally I used "Gnome Fallback" as my desktop manager and all of a sudden I got a cursor.

This works for me now, although I would really like to try using the new KDE desktop as well as Unity.

It appears to me to be a problem with compiz (perhaps) or at least has something to do with the VMWARE XORG drivers as they interact with 13.04 (my guess).

Hope this helps someone else out .. maybe someone can figure it out from here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.