25

In 10.04, I had a lot of keyboard shortcuts defined using Super/Mod4 and one single other key,

  • Super+O ran Opera
  • Super+W opened Nautilus pointing to my Work folder, etc.

In 11.04, these do not seem to work -- only Super+R works to run the terminal, and Super+Shift+W successfully runs Nautilus.

Is there some way I can get these to function again?

Adding them in Keyboard Shortcuts does not work, and neither does adding commands in CompizConfig Settings Manager.

4
  • 1
    Are you adding commands in the Commands plugin for ccsm? It works fine for me: just make sure to remember to set both the command and they key-binding :P
    – MarkovCh1
    Commented Apr 8, 2011 at 19:37
  • Yep, I did that, as I wrote, and set the keybindings, but it didn't work until I removed the Launcher binding, as instructed below.
    – Rasmus
    Commented Apr 11, 2011 at 9:15
  • 2
    Follow-up for 12.04: I encountered a problem updating to 12.04, namely that some shortcuts did again not work and some had been altered. Under System Settings > Keyboard > Shortcuts, some of my custom shortcuts had been changed from Super+<key> to Mod4+Super+Hyper+<key>. These wtill worked, so did all with other modifiers, i.e. Ctrl+Super+<key>. Pure Super+<key> did not work when set in that dialog. Setting them in CCSM using the Commands plugin does work (in conjunction with the answer below).
    – Rasmus
    Commented Apr 26, 2012 at 12:47
  • I must say that I'd really appreciate if the Dash/Launcher <kbd>Super</kbd> shortcuts could be modifiable individually. I generally like the concept, but I'd like to live without several shortcuts like <kbd>Super</kbd>+<kbd>G</kbd> that I'm used to use in terminator.
    – tlwhitec
    Commented Feb 4, 2015 at 15:51

3 Answers 3

33

This happens because in Natty Super/Mod4 is a shortcut to the Unity panel. You can change that in Compiz.

  1. Install the compizconfig-settings-managerInstall compizconfig-settings-manager package.

  2. Hit Alt+F2, type about:config and hit Enter to open the Unity configuration.

  3. Change the shortcut for Key to show the launcher as you like to free your Super key:

    enter image description here

In this example I've changed from Super to Super + L

Now your mod key is free to use as you like.

5
  • 2
    One downside to this is that Super+(number) no longer works to quickly switch between apps, at least not on my Azerty keyboard. Commented Apr 23, 2013 at 10:31
  • You are right .
    – desgua
    Commented Apr 23, 2013 at 22:32
  • You may also find the first answer at askubuntu.com/questions/378037/… helpful to see what your key mappings are. Commented Mar 29, 2014 at 11:30
  • I cannot find the equivalent to this in ubuntu 14.04, would you know where that would be?
    – Three Diag
    Commented Jun 28, 2015 at 16:15
  • In Ubuntu 14.04 you can assign "Super"+"Key" to a shortcut without needing to change de launcher shortcut.
    – desgua
    Commented Jun 28, 2015 at 16:45
6

To do this without installing anything and without having to navigate the unfamiliar menus.

  1. Press Alt+F2
  2. Type gnome-terminal Enter
  3. Type gconftool-2 --set --type string /apps/compiz-1/plugins/unityshell/screen0/options/show_launcher '<Super>a' Enter

Change the a after <Super> to whichever key you prefer.

Note that s and w are already taken, and I wouldn't recommend using l because that's often used for lock screen.

1
  • 2
    Running gnome-terminal is recommended because you can't paste into the Alt+F2 dialog. Bug 736222.
    – Mikel
    Commented May 2, 2011 at 0:07
0

Simpler from here: In System Settings / Keyboard / Typing tab / Layout Settings link (at the bottom) / Layouts tab / Options button / "Alt/Win key behaviour", choose Meta is mapped to Left Win key.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .