0

Does anybody know how to install Xen 4.3.0 on Ubuntu Precise? I'm compiling from source and all seems fine but it does not boot into the hypervisor. No files appear in '/boot/xen/' with a *.gz extension.

Installing with Xen 4.2.2 works fine. I'm following instructions within the source file download from XenProject. Following their instructions as well - http://wiki.xenproject.org/wiki/Compiling_Xen_From_Source

What can cause this? What's the fix?

1

use sudo checkinstall -y instead of sudo make install

see https://help.ubuntu.com/community/CheckInstall

the xen kernel will be installed in /boot unless you have overridden the default install locations

  • Not sure if I had to do this when I compiled 4.3 but it makes it a lot easier to install/backup your xen, just make sure you set the version when it ask if you want to set anything otherwise it fails (for me at least) – Gilsham Dec 12 '13 at 2:52
  • Checkinstall was a great suggestion! It has helped in installing software other than Xen! Thanks a lot! About the problem no solution yet. – user189796 Feb 25 '14 at 4:41
0

Xen is in the mainline kernel now, so you don't need to look for separate xen kernels. If you are using grub, the following will get up booted into xen 4.3+, assuming you just did your make install and /sbin/ldconfig (All of my commands assume you are root. Add the sudo if you want):

dpkg-divert --divert /etc/grub.d/08_linux_xen --rename /etc/grub.d/20_linux_xen
update-grub

Then you can reboot! But you're probably not done..

Also, when compiling from source you don't get boot scripts setup in ubuntu, so you have to set them up yourself.

I don't use xm, so I immediately disable it:

update-rc.d xend remove
update-rc.d -f xend remove

Then I add all of the xen deamons to rc scripts. I use level 99 because I have a bunch of stuff like zfs, nfs, etc that I like to boot before my domUs boot/restore. You can leave off the 99 if you feel like it.

update-rc.d xencommons defaults 99
update-rc.d xendomains defaults 99
update-rc.d xen-watchdog defaults 99

Then I start up the services:

/etc/init.d/xencommons start
/etc/init.d/xendomains start
/etc/init.d/xen-watchdog start

And list the domains to see what a good job I did:

xl list

All of this stuff should really be on that Compile from source page you linked under ubuntu/debian specific post-compile tasks. Anyway, I hope this helps!

Bonus Sysadmin Tip!!

If you are trying to figure out why your xen commands aren't working, the first step is always to check which services are running. For xen, a good way to do this is with ps:

ps -ef |grep xen

That will list out any processes with xen in the name, which are the important ones for the scope of this question. if you see xend or Xend in the list(but not xendomains, because you need that) then you are using the xm toolstack, which conflicts with damn near everything. Again, good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.