Hey everyone I have an ASUS laptop that came with windows 8 and of course UEFI(ugh) with a 500GB HDD and 20GB SSHD, this is a hybrid drive.

I tried to wipe windows and install just ubuntu, I did this like normal with a partition scheme as noted below:

10 GB - root on the SSD

100 GB - home on the normal disk

100 GB - var on the normal disk for hosting files / dropbox folder / web dev

1 GB - boot partition on SSD

10 MB - bios boot partition on SSD

I left the rest of my drive empty I want to install backtrack also in a dual boot (that will be another post im sure but Im using that live for now).

After I did this I found that windows was giving me an error upon boot and no linux OS's were detected from the boot menu period.

I could also not boot my linux dvd for some reason :S

I think installed a linux live USB I had made for fun and when it loaded the BIOS/UEFI I saw my EFI usb stick and saw my cd, so i booted from my cd again. (this was freshly burnt @ 4x from the ubuntu website).

I thought I found the issue and that was because I did not delete the 4GB windows boot partition, so I deleted it, I'm thinking I might have made a mistake I read i cant update my bios without it but I don't know the validity of that statement and can not find a reference.

I then proceeded with an an exact install as noted above (remember i deleted my windows boot partition this time). And I received and error that said:

No File Found

GRUB recovery:

Or something very close, booted into the UEFI/BIOS and made sure I have CSM enabled, Secure Boot disabled and PXE disabled also(just checking..!) I do not have an option to boot into anything except my 500GB drive with no GRUB or boot or bios or root, and a my dvd drive (thankfully)

So I inserted my ubuntu disk again and I am going to try this once more with the same setup and report back but any help on this topic will be appreciated. I will report my progress asap and keep and eye out. I need this puppy running for school tomorrow and I refuse to find a windows 8 install and I really don't want to go with windows 7 either I bought this laptop to hack (ethically of course) and code not to use Skype and play farmville.

Why do you do this to us microsoft, we don't want run your resource stealing OS unless I need to use itunes, adobe audition, FL studio or PS(I know, "GIMP", yeah whatever). Even steam can see the future. Sorry for venting but this UEFI thing is just plain wrong, it must be a legal loophole.



I think I might of found the issue I didnt choose my dev/sb3 (boot partition) as my GRUB install path I think it was set to dev/sb1 (which was root)

I also changed all my drives from ext4 to ext3 where applicable.

Awaiting install procedure...



No go same error:

I ran the output of ls and saw a few drives

(hd0) (hd0, msdos5) (hd0, msdos2) (hd1)    

insmod (hd0)/boot/grub/linux.mod
unknown filesystem

insmod (hd0, msdos5)/boot/grub/linux.mod
file not found

insmod (hd0, msdos2)/boot/grub/linux.mod
file not found

insmod (hd1)/boot/grub/linux.mod
unknown filesystem

My UEFI/BIOS SATA config shows my 500GB drive as SATA 0 and my 24GB drive as SATA 1. I still do not have a boot option for my 24GB(which is where the GRUB is). I only see my dvd and my 500GB. My Sata was set to AHCI mode instead of IDE. Why do these say msdos in them. I found this problem and it was related to the /boot partition not being at the beginning of the drive, i shall try that and report back.

  • Your verbal description of your configuration is imprecise enough that it's impossible to tell what's going on. You can try running Boot Repair, which might manage to fix things; and if it doesn't, it should produce a URL that will point to a page with detailed information on your system for human diagnosis. – Rod Smith Sep 4 '13 at 1:01
  • Im brushing up on my communication skills at school actually I completely agree after re reading most of it, at least the other fellow understood the issue. – chrstphrmllr Sep 4 '13 at 22:36

The bios_grub partition is for booting BIOS based machines, not UEFI. For that you need to create an EFI system partition instead. Also you don't need a separate /boot partition.

The grub install path should be /dev/sda, with no partition number ( or sdb if that's where you put the EFI system partition ). Set the EFI system partition to be mounted in /boot/grub/efi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.