1

I have a problem, im using 12.10 Ubuntu. Recent i sound settings gui working. Now it not working. How to get master gui working? My sound working but audio (master) slise in mute permanently also audio settings are empty. However in flash, spotify etc slides working. Also MUTE button is removed.

My alsamixer working.

My hwinfo is this.

 hwinfo --sound
24: PCI 709.0: 0401 Multimedia audio controller                 
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_13f6_111
  Unique ID: GKX6.fT7WCdwsUsC
  Parent ID: 6NW+.FukESQtKoV4
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:07:09.0
  SysFS BusID: 0000:07:09.0
  Hardware Class: sound
  Model: "TERRATEC Aureon 5.1"
  Vendor: pci 0x13f6 "C-Media Electronics Inc"
  Device: pci 0x0111 "CM8738"
  SubVendor: pci 0x153b "TERRATEC Electronic GmbH"
  SubDevice: pci 0x1144 "Aureon 5.1"
  Revision: 0x10
  Driver: "snd_cmipci"
  Driver Modules: "snd_cmipci"
  I/O Ports: 0x1000-0x1fff (rw)
  IRQ: 21 (336 events)
  Module Alias: "pci:v000013F6d00000111sv0000153Bsd00001144bc04sc01i00"
  Driver Info #0:
    Driver Status: snd_cmipci is active
    Driver Activation Cmd: "modprobe snd_cmipci"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #20 (PCI bridge)
1

Resetting User Configuration

For some reason, pulseaudio's user configuration files can become corrupt(unsynced?) in some way, and deleting them (and forcing fresh ones to be generated) fixes a no sound condition. After using the command below, log out/in.

Ubuntu 12.10/Quantal (and earlier)

rm -r ~/.pulse*; pulseaudio -k
0

You can give a try to command line interface for your sounds settings, if GUI doesn't work for you..

  • Install gnome-alsamixer (open terminal CTRL+ALT+T then execute following command):

    sudo apt-get install gnome-alsamixer
    
  • Run gnome-alsamixer:

    alsamixer
    

    on the same terminal AlsaMixer will be opened.

  • Use -> or <- arrow keys to change the options. Up and down arrow keys to increase/decrease volumes. M key to Mute. Press Esc to exit.

Hope this short description helps you any how. Reply if something goes wrong.

  • Yesterday gui working. But today crashed. And reboot not working. Where is config files? – lahtis Sep 3 '13 at 21:22
  • Is alsamixer working from terminal? What are the scenario you are getting? – Saurav Kumar Sep 4 '13 at 5:55
  • yes is working. my pulseaudio settings are corrupted. it is fixed now. – lahtis Sep 5 '13 at 14:00
  • Then edit my answer and list the changes you did to fix your problem, then mark this question as solved. It would help others to solve such problems.. :) – Saurav Kumar Sep 5 '13 at 15:21
  • how to mark question solved? – lahtis Sep 6 '13 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.