3

I've the following configuration:

A. Physical machine: Windows 7 64bit with VMWare workstation 8 with a physical network adapter with this ip configuration:

IP 192.168.1.101
Subetnet Mask 255.255.255.0
Gateway 192.168.1.254

and a virtual network adapter (VMNet8) with this configuration:

IP 10.10.0.18
Subnet IP: 10.10.0.0
Subnet mask: 255.255.255.0

B. Virtual machine: Ubuntu 12.04 server (running in VMWare workstation 8) with the following ip configuration (in /etc/network/interfaces):

auto eth0
iface eth0 inet static
address 10.10.0.1
netmask 255.255.255.0
gateway 10.10.0.18

with this routing table (route -n):

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.10.0.18      0.0.0.0         UG    100    0        0 eth0
10.10.0.0       0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.1.0     10.10.0.18      255.255.255.0   UG    0      0        0 eth0

The problem is that the virtual machine is not accessing the internet nor pinging the physical machine, in particular:

(from the physical machine)

  • internet is accessible
  • ping 10.10.0.18 is working
  • ping 10.10.0.1 is working

(from the virtual machine)

  • internet is not accessible
  • ping 10.10.0.1 is working (it's itself)
  • ping 10.10.0.18 is working
  • ping 192.168.1.101 is NOT working
  • ping 192.168.1.254 is NOT working

I've tried the answer here: Configuring Ubuntu vmware guest NAT but it's not working.

Any suggestion will be greatly appreciated.

4
  • Do you have any other networking stacks, or VPNs installed on the host, such as VirtualBox, CiscoVPN, etc? Sep 3, 2013 at 18:56
  • What is the reason to make the Guest machine with a fixed ip? Also, are you using NAT or Bridge?
    – Braiam
    Sep 3, 2013 at 19:07
  • @rosss no other networking stacks or VPNs
    – Mevio
    Sep 3, 2013 at 19:33
  • @braiam fixed IP becaus it's a development web server and I need it; I'm using NAT on vmnet8
    – Mevio
    Sep 3, 2013 at 19:34

2 Answers 2

0

The gateway in your route table is set to the IP address of the host's VMNet8 interface whereas it should be set to the gateway address of the NAT interface. If you run the Virtual Network Editor and look at the NAT settings for the VMnet8 interface, you should find the gateway IP. Try setting the gateway to that address in the virtual machine.

Hope that helps.

1
  • thanks for the answer, the problem was that the Gateway IP in the NAT settings of VMnet8 was the same of the IP address. I've change the gateway IP to 10.10.0.254 and changed the ubuntu network settings accordingly and now it's working.
    – Mevio
    Sep 3, 2013 at 21:13
0

I have the alike issue. Finally, I checked the Win7 service and application. Find VMWare DHCP Service and NAP service is not running and start with fail. I checked the Registry, finding the two key value wrong, I edit these values with correct values set the NAT DNS with host's DNS. Then the host can communicate with VM each other. And VM can access the Internet.

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.