As soon as I suspend my mbp the led starts pulsing after a while but by opening the lid Xserver hangs, I get a black screen and am presented with the login screen after 2 minutes. Logging in results in the same procedure( black screen -> wait -> login -> ...) I somewhere read that the nouveau driver is causing this so I tried to install the nvidia driver (304) on my ubuntu system(13.04) from console because it wasn't listed in the additional drivers tab. The driver causes the monitor to be shut off (black and no backlight) after the kernel started up(logging in and shutting down from terminal works). After 'apt-get purge nvidia-*' everything is back to normal( monitor works, suspend doesn't) Btw: I have an Nvidia gt330m with a hi-res 1680*1050 display Is there anything I can do about it to get suspend to work and even better the nvidia driver?

2 Answers 2


I just ran into the same black screen issue, and it is highly frustrating. Log into your grub menu by holding shift while booting up your mbp, edit the kernel arguments with e, and right before silent splash you should add - nomodeset so it should look like what this guy here has done - http://ubuntuforums.org/showthread.php?t=1613132. If this solves the problem for you, continue with the rest of the instructions for setting it permanently.

ok, I've done some looking into this, since I am also currently working on getting my nvidia 740m to work. By the way, your graphics card uses nvidia optimus, so as a side note, you may want to look into bumblebee. But which nvidia drivers are you using? The 319 is the stable release, but not available in the repository However, the 325 beta drivers are available, and It noted some fixes to screen flickering in relation to scaling windows such as ours, so I believe this may be as useful to you as me. I am assuming you are referring to 319 however, but just incase you are not I will provide some links. And for your xconf not working, you could try this:

sudo /sbin/lsmod | grep nvidia

To make sure that it is loaded, if not you will have to load it manually like so:

sudo depmod -a
sudo modprobe nvidia_current

If you have issues with that, I would also recommend checking out additional drivers. If you do not have any listed, try this:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update

and check again, there should be some there. Then purge your current proprietary driver and use those and reboot, and enter this:

sudo nvidia-xconfig --sli=On

Since your card is an optimus, it is best practice to not install nvidia drivers that have optimus though, as there are many issues. So you should install bumblebee to run your graphics intensive programs, and just use the additional drivers or the nvidia-current. If you happen to run into that screen resolution error again, you can use optirun to load your nividia setings directly as well.
Also if you are interested, your graphics card also has support for CUDA, and since this is linux, the drivers don't support this by default just yet, you can install CUDA. There is some better explanations of that here as well.
How can I get nVidia CUDA or OpenCL working on a laptop with nVidia discrete card/Intel Integrated Graphics?
And you can get the toolkit from here:

Here are the links if you still wish to try those proprietary drivers:

And here is the link referring to the brokn unity window:
After upgrading to 13.04 Unity interface is not showing.

Hopefully this has helped some, if not, let me know and I ill look into it.

  • I tried to install the nvidia_current driver but however hard I tried I failed (nvidia-settings said there was no xconfig file and I should run nvidia-xconf which was just not installed. Sep 6, 2013 at 5:20
  • The newest stable driver from the nvidia site however appears to do sth but no window decorations no unity and stuck with 640x480 resolution (was able to change via xrandr with a manual mode to 1680x1024). The good thing is resume appears to work just fine. Sep 6, 2013 at 5:25

On the Mac Book Pro 6,2 it is impossible to install a proprietary Nvidia Driver while booting in EFI-mode. Bumblebee can also only be used with the nouveau driver. To solve the problem I followed the instructions on https://help.ubuntu.com/community/UEFI: """ Converting Ubuntu into Legacy mode If Ubuntu is installed on a GPT disk (you can check it via the 'sudo parted -l' command), use Gparted to create a BIOS-Boot partition (1MB, unformatted filesystem, bios_grub flag) at the start of its disk. Start Boot-Repair, click on "Advanced options", go to the "GRUB location" tab. Untick the "Separate /boot/efi partition" option Click the "Apply" button. Set up your BIOS so that it boots the HDD in Legacy mode (see the ""Set up the BIOS in EFI or Legacy mode" paragraph above). """

After that I had to bless the newly installed Bootloader in OSX to make it bootable: "sudo bless --device /dev/disk0s1 --setBoot --legacy" Replace /dev/disk0s1 with the partion you installed grub on earlier.

After a reboot I was now able to install the newest nvidia driver from the additional drivers tab. This fixes the suspend/resume bug and increases battery life.

The only drawbacks are that grub resolution can't be set higher than 1200x800x32, the boot sequence is displayed in black and white with 640x480 and so are all the TTY's.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.