i'm on ubuntustudio and i want to format my hd and try kubuntu (install in my acer notebook, no partion, no double operating system problem, only istall it) i've downloaded iso file ( kubuntu-10.10-desktop-i386.iso ), insert usb pen drive, then: system > administration > startup disk creator erased usb pen content, and "make startup disk" finally, reboot computer with pen inside usb port

normal boot didn't start (as expected) but only black screen with this signal:

SYSLINUX 4.03 2010-10-22 EDD Copyright (c) 1994-2010, H. Peter Anvin et al
unknown keyword in configuration file

i've tried different usb pen stick and different iso files (ubuntu, kubuntu, netbook edition).. always same problem (sometimes only the first line without "unknow keyword in conf file" error)

some advice?? sorry for my bad english

5 Answers 5


In 10.10 there is a bug in usb-creator that may cause your problems. Try creating your stick using UNetbootin, as was just suggested.

There are reports that you can fix the bug by opening syslinux.cfg on the USB drive and replace the following line:

ui gfxboot bootlogo


gfxboot bootlogo
  • 1
    yeah i found the bug and its fix here: alexsleat.co.uk/2010/11/27/… now.. people knows there is the bug and knows how to fix it (remove 'ui' word in syslinux.cfg).. why it is not fixed in main distributions?
    – nkint
    Apr 8, 2011 at 12:07
  • ty for the info. Added it to answer :)
    – Takkat
    Apr 8, 2011 at 12:22
  • Perhaps i tried with UNetbootin, I got the same error. But before completely formatting the USB Disk. I used a usb stick that was having ubuntu 14.04. Now i formatted and created bootable usb using unetbootin, now it worked like a charm. Lesson : Deleting files / overwriting exsiting old Ubuntu 14.04 or other os also may cause this problem, So Format the disk before flashing the USB Stick as a bootable disk. Feb 8, 2020 at 18:13

Okay, the problem is that you didn't format your USB to FAT32.

  • how to save the data inside anyway?
    – nkint
    Apr 1, 2012 at 21:55
  • Also try FAT16 (aka "FAT"). FAT32 is not bootable on some hardware, whereas FAT16 may be.
    – Nik
    Aug 4, 2013 at 7:31

You could try using UNetbootin, another tool for the same purpose of making bootable usb drives. It's in the repositories as unetbootin.


Actually, what worked for me [Dell Power Edge Server R220] was to copy the iso to usb in the following manner

I inserted usb drive then ran dmesg | tail to know the /dev/sd<x> drive.

If this drive has partitions then make sure you unmount invidual partitions sudo fdisk -l /dev/sd<x> first sudo umount /dev/sd<x1>; sudo umount /dev/sd<x2>; ... etc.

Then format this as follows sudo mkfs.msdos -I /dev/sd<x>

Now copy over the iso sudo dd if=<iso name>.iso of=/dev/sd<x> bs=1M && sync


I solved this problem by copying syslinux.cfg from one folder near the kernel to the base of the Key. In fact I once displaced it and the boot went one step further but syslinux.cfg was then missing to the boot. So I had to copy it back.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .