1. I was updating kernel, mesa, firefox, thunderbird, python and some other packages on 28/8/2013. My internet connection terminated while updates were ongoing. So Laptop did not started in next reboot.
  2. I read all post regarding editing grub menu and setting nomodeset option along with other options but none of them worked for me.

    Except quiet splash nomodeset vga=0×31 and quiet splash i915.modeset=1 gave me front booting screen, but no avail,like dots moving in a front screen of Ubuntu... It did not bootup though. Only option was CTRL+ALT+Del when I press CTRL+ALT+Del it starts booting...it shows dots moving...but since it is rebooting, it does not load Ubuntu.

  3. when I pressed CTRL+ALT+F2, command line shows up, when i tried to run firefox from command-line, it shows message: no display specified x11 initiallization failed

  4. I tried to run in failsafe graphic mode but got error message as:

    xinit/;unable to run server /usr/bin/x
    non integer argument  /usr/shre/xdiagnose/failsafeserver:line 87: [ -lt:unary operator expected
    gdm:unrecognized service
    stop:unknown instance:
    xinit /usr/share/xdiagnose/failsafe
    xinit /etc/x11/xorg.conf.failsafe with- -- /usr/bin/x -br -once -config 
    /etc/x11/xorg.conf.failsafe -logfile
    xinit:unable to run server "/usr/bin/X" no such file or directory

    P.S. But I checked at /usr/bin/Xorg I found server is present there

  5. Error message in /var/log/syslog : ACPI _OSC request failed, returned control mask:0x1d

  6. Not able to boot from LiveCD: When I tried to boot from pendrive, laptop shows a blank screen with blinking cursor, after waiting for 15 min, no progress so hard reset.

  7. Don't suggest me to replace Ubuntu 12.04.

  8. My laptop configuration is: Samsung NP300E5Z, 4GB RAM, Intel i5 2nd generation with inbuilt graphics 3000 series, Windows7 and ubuntu12.04 in dual boot mode.

  9. I am able to login to Windows without any problem, so I think it is not Grub problem.

I checked almost 40 posts and related discussion, but none of them worked for me.

2 Answers 2


Try following steps once to fix your problem

  • When your system starts press CTRL+ALT+F1 to go to CLI tty1, login using your credentials.
  • Then execute following commands in series, i,e one after another:

    sudo apt-get autoremove
    sudo apt-get autoclean
    sudo apt-get --purge remove $(dpkg -l | grep "^rc" | awk '{print $2}' | tr '\n' ' ')
    sudo apt-get update
    sudo apt-get -f install
    sudo apt-get dist-upgrade
    sudo apt-get upgrade
  • If everything goes fine then reboot your system and check whether it solves your issues. Run this command to reboot your system:

    sudo reboot

You can also give a try to fix your problem using Safe Mode if above method doesn't help you

  • When your system starts chose Recovery Mode (2nd option in grub menu).
  • From the Menu just go to Grub option, it will give a message like Updating grub will mount your system in read/write mode. Just chose yes to mount your system in read/write mode. It will update your grub and will exit from Grub menu.
  • chose network option it may enable your network.
  • Then chose dpkg menu from the list, chose yes for all.
  • Finally chose root option and login. Execute following commands one after another:

      apt-get autoremove
      apt-get autoclean
      apt-get --purge remove $(dpkg -l | grep "^rc" | awk '{print $2}' | tr '\n' ' ')
      apt-get update
      apt-get -f install
      apt-get dist-upgrade
      apt-get upgrade

    Then reboot your system and check whether your are able to use Ubuntu or not. Run this command to reboot:


Hope either of this method works for you.. Reply if something goes wrong.

  • Thanks saurav. I tried to execute all commands but I am not able to connect to internet. I tried with photon data card, mobile tethering but no help.
    – dkb
    Sep 3, 2013 at 16:18
  • Then what happened? Can you provide some extra information? Sep 3, 2013 at 16:19
  • I have mention all my tried methods in question. You need extra info about??
    – dkb
    Sep 3, 2013 at 16:23
  • Have you tried my suggestion at least once? All the commands I have mentioned will fix broken packages, try to download missing packages, update your system to new packages, try to fix unmet dependencies, and hence try to fix your system! Sep 3, 2013 at 16:27
  • At last reinstallation of ubuntu was inevitable so reinstalled ubuntu.
    – dkb
    Mar 8, 2014 at 14:00

I had the same issue, Ubuntu had deactivated networking, so one must access the command line and do the following steps:

  1. mount read/write
  2. enable networking
  3. run all the commands to update and upgrade

Here are the commands, do them one after another:

sudo mount -o remount,rw /
sudo service networking start
sudo apt-get update
sudo apt-get -f install
sudo apt-get dist-upgrade
sudo apt-get upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.