I have a windows 8.1 preview (upgraded from 8) on my system. I have one HDD or 1 TB, with one drive 228 GB for ubuntu.

I downloaded 13.04 (64 bit) from ubuntu's site. used pendrivelinux to create a bootable usb. restarted the computer, and booted from USB (from UEFI menu). selected try ubuntu without install installed ubuntu made 4 partitions:- boot, root, home and swap. all went well and the prompt came asking me to restart the system. Once i clicked the restart button, windows loaded without asking for any OS choice.

so i restarted the system again went into boot menu, which showed, ubuntu also. Selected it and pressed enter, again windows loaded.

So i googled a bit and installed easybcd, this is what it said.

There are a total of 3 entries listed in the bootloader.

Default: Windows 8.1 Preview
Timeout: 30 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Ubuntu
BCD ID: {63712191-130f-11e3-bef6-84a6c82584a5}
Device: \Device\HarddiskVolume1
Bootloader Path: \EFI\ubuntu\grubx64.efi

Entry #2
Name: EFI USB Device
BCD ID: {0bd5b854-4556-11e2-8925-d4bed9614efa}
Device: Unknown
Bootloader Path: 

Entry #3
Name: Windows 8.1 Preview
BCD ID: {current}
Drive: C:\
Bootloader Path: \WINDOWS\system32\winload.efi

I tried adding a new entry also as told on many sites, but all in vain.

I checked to see if ubuntu is actually installed or not. So when i tried to reinstall ubuntu, it said that it is already installed.

So what can I do now?

Based upon the suggestion, i installed boot repair. ran boot repair and selected recommended option in boot repair. system said that i need to turn off secure boot. and then completed saying that i can restart. On restart nothing changed with or without the secure boot disabled. That is no boot menu. straight away going to windows.

So i logged in again via USB installed boot repair again. ran boot repair in advanced mode, but wit default options checked. system asks me to run a few commands (3) followed by another command. then says to restart.

On restart this time the USB loads itself, as if there is no windows or ubuntu installed. I checked the boot menu and there is no windows or ubuntu.

Current boot info summary is: http://paste.ubuntu.com/6059160/

Currently I have secure boot off, i guess i t is required to be disabled for dual boot.

in advanced boot, the default option selected was sd6 for /boot partition and sd1 for boot/efi partition

My boot repair screen is different from your's.

Then I went ahead and reinstalled ubuntu (deleted the previous install) Ubuntu is working fine now.

Now i need to find a way to bring back windows to life. Please suggest how to do that.


Boot from a live Ubuntu USB pendrive or CD and
Install Boot-Repair on ubuntu by following steps

Open the terminal and run the following commands

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair

After completing the installation you can launch it from System->Administration->Boot-Repair menu if you use Gnome, or search "boot-repair" in the dash if you use Unity. Then follow the following screenshots:

Method 1

  • Click on the advanced options

Initial screen

  • Tick the options shown below

advanced option

  • Change the tab to Grub Location Tab and Tick The options Shown in the figure

enter image description here

Press Apply and Reboot the system

Method 2

  • Select the recommended Boot repair options as shown in the first screenshot

Documentation :

|improve this answer|||||
  • Hi, Thanks for the instruction. Let me tell you I am one day old with respect to ubuntu. the 3 lines for installing helped. As i know nothing so, i went ahead and chose the recommended option. It asked me to disable the boot secure boot option, i said yes. It then repaired the boot file. Took backup of the windows boot file. (I guess) paste.ubuntu.com/6056110 this is the paste link. I am going to restart the system now to see what happens (without disabling the secure boot). Please let me know what are the affects of disabling the secure boot. Thanks & Regards, Shivam Verma – user189491 Sep 2 '13 at 18:26
  • Hi, the restart did not work. with or without the secure boot disabled. – user189491 Sep 2 '13 at 18:39
  • And now i am not able to log into Windows as well. This is a new problem that I have created. Guess both have the same solution. – user189491 Sep 2 '13 at 18:40
  • Error that i am getting is: Failed to open \EFI\Microsoft\Boot\grub64.efi Failed to load grub failed to open \EFI\BOOT\grubx64.efi failed to load grub checking media [Fail] – user189491 Sep 2 '13 at 18:44
  • @user189491 Is this what you are getting? askubuntu.com/questions/262904/… – Stormvirux Sep 2 '13 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.