I'm running ubuntu 9.10 x64, with the stock tightvncserver (1.3.9).

When I start tightvncserver, I can connect with the windows tightvnc client and get the empty desktop with a single terminal. When I then try to start gnome-session it promptly crashes.

The last lines on the tightvncserver log are:

01/09/10 10:53:18 Got connection from client
01/09/10 10:53:18 Using protocol version 3.8
01/09/10 10:53:18 Enabling TightVNC protocol extensions
01/09/10 10:53:20 Full-control authentication passed by
01/09/10 10:53:20 Pixel format for client
01/09/10 10:53:20   32 bpp, depth 24, little endian
01/09/10 10:53:20   true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0
01/09/10 10:53:20   no translation needed
01/09/10 10:53:20 Using tight encoding for client
01/09/10 10:53:20 rfbProcessClientNormalMessage: ignoring unknown encoding 8
01/09/10 10:53:20 Enabling X-style cursor updates for client
01/09/10 10:53:20 Enabling cursor position updates for client
01/09/10 10:53:20 Using image quality level 6 for client
01/09/10 10:53:20 Enabling LastRect protocol extension for client
01/09/10 10:53:20 rfbProcessClientNormalMessage: ignoring unknown encoding -223
xterm:  fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":3.0"

The output from gnome-session (obtained from gnome-session | tee output) is:

** (<unknown>:2779): DEBUG: Client registered with session manager: /org/gnome/SessionManager/Client2
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: not present.
aborting and using fallback: /usr/bin/metacity

I've checked the /var/log/Xorg.0.log but this contains nothing pertinent to the vnc session.

I am currently successfully using tightvncserver on other 9.10 systems. The system which exhibits the problem does not differ from my other working systems in any way that seems significant to me.

What I'd like to know is:

  1. What I should be doing to find out further information on what is failing
  2. What is causing the crash
  3. How can I fix it?
  • Have you tried plain ol' xllvnc?
    – Oli
    Sep 1, 2010 at 9:10
  • 1
    My understanding is x11vnc is to turn an existing, 'authentic' X session (ie is output to a physical monitor) into a vnc connectable session. I OTOH want to create a new X session that is purely vnc based.
    – adante
    Sep 2, 2010 at 0:51
  • you didn't have correct xstartup file, follow this instruction namhuy.net/3106/install-vnc-server-ubuntu-14-04.html Jun 6, 2014 at 7:31

2 Answers 2


To answer how to diagnose your problem specifically, the first step would be to enable apport crash reporting on the system and then attempt to reproduce the crash. Once you've caused TightVNC to crash again, if it was the type of crash that apport should catch, a crash report should have appeared in /var/crash. You should be able to point ubuntu-bug at the crash report file to have it submit a bug report to launchpad.

That said, a while back I went through several of the vnc servers, looking to use one in the way you describe, as a separate session rather than to duplicate a running desktop. As I recall, tightvncserver crashed on me a lot, and based on the launchpad bugs for the package, it seem that a few other people see the same thing.

I ended up using vnc4server Install vnc4server, which has worked pretty well for me over multiple releases. That said, in maverick, I'm getting bitten by bug 655886 when using a gnome session, so it's not perfect.


I've had a lot of problems when using tightvnc when desktop effects are enabled (eg. compiz). Try disabling compiz and see if that solves your problem. You can disable it via System --> Preferences --> Appearance, and then selecting the Visual Effects tab (Select "None").

If that doesn't help you out, you'll probably have to run gnome-session using the strace tool. This will display every system call that gnome-session is running and hopefully give an indication of which one is causing you troubles.

  • Doesn't seem to be compiz. I couldn't figure out how to disable it from the command line so I simply uninstalled it, but the error persisted. I've run strace but totally don't comprehend the output (300kb file). Incase you are interested the last 1000 lines are here: pastebin.com/W50aHikC
    – adante
    Sep 1, 2010 at 6:37

Not the answer you're looking for? Browse other questions tagged .