I put my home folder on its own partition following the instructions in the Ubuntu Documentation Partitioning/Home/Moving wiki.

Now I'm not the owner of my own home folder. How can I fix this? I can't use Wine because it says I have to be the owner of my home folder. When I use sudo nautilus then try to change permissions, it reverts to root every time I select myself or any other group. Is there a command I can use to make myself the owner of my home folder?

I have already tried the following commands:

    sudo chown -R username /home/username

• This one wouldn't work, it replied: chown: cannot access '/home/aaron/.gvfs': Permission denied

sudo chown -hvR username:username /home/username  

• This one output all of my files' names telling me that their ownership was changed, but when I went and checked it still said root.


1 Answer 1


I have faced this problem and solved by using a trick. You are getting chown: cannot access 'home/aaron/.gvfs': Permission denied error because .gvfs directory is in use.

What I suggest you to do.

  • Restart your system in Recovery Mode and follow these steps.

    • First chose the option Grub from the Menu listed there, accept yes. It will mount your file system in read/write mode. After updating it will exit from the Grub and will come back to Menu. Then chose root.

    • Now you execute all your commands that have you tried above again.

    • It would successfully change the permission. Then run following command to reboot your system.

      # reboot
  • 2nd way is little tricky. But you can give it a try. Hope it works for you also, it worked for me.

    • Press CTRL+ALT+F1 to go to tty1 and login with your username.
    • Execute following command:

      sudo pgrep $ | sudo xargs kill
    • It will display some message and wait for your next instruction. Do nothing just just press CTRL+ALT+F2 to go to tty2 and again login.
    • Here you have to run your commands to that you have already tried to make change your permission of your home.
    • Then go back to previous tty1 CTRL+ALT+F1 and press CTRL+Z or CTRL+C.

    • Press CTRL+ALT+F7 or CTRL+ALT+F8 to get your display back. you can also use ALT+ -> continuous to get your display back.

Hope it will work for you. Reply if something goes wrong.

  • The first way didn't show any errors, but when i logged back on i still didn't own my home folder. I couldn't get the second way to work, in tty1 it would say caught signal 15 shutting down, and tty2 said my home folder didn't exist... i think the problem might be in fstab where it gives permissions when it mounts the home partition...
    – user189100
    Sep 2, 2013 at 17:09
  • I'm just going to reinstall ubuntu and see if that works...
    – user189100
    Sep 2, 2013 at 17:34
  • I don't know for you why it is that much tough. Did you check your commands to give permission to /home? Sep 2, 2013 at 17:50
  • I just reinstalled ubuntu and kept home on the same partition as the OS, now all the other problems i was having such as wine, sound, etc are now working. I'll just leave it this way.
    – user189100
    Sep 2, 2013 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.