My dual-boot computer is displaying two boot managers in a row: first the Windows 7 boot manager with the choices:

  • Windows
  • Linux

and then, when I choose "Linux", it goes to the Grub menu:

  • Ubuntu
  • Advanced options for Ubuntu
  • Memory test
  • Windows 7 (loader) on /dev/sdb2

This double boot manager behavior is silly -- how can I boot directly into grub, bypassing the Windows boot manager?

My disk setup has Linux on /dev/sdb1 and Windows on /dev/sdb3:

$ sudo parted -l

Model: ATA WDC WD30EFRX-68A (scsi)
Disk /dev/sda: 3001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name                          Flags
 1      17.4kB  134MB   134MB                Microsoft reserved partition  msftres
 2      135MB   2148GB  2147GB  ntfs         Basic data partition
 3      2148GB  3001GB  853GB   ext4         Basic data partition

Model: LSI 9750-4i DISK (scsi)
Disk /dev/sdb: 960GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size    Type      File system     Flags
 1      1049kB  826GB  826GB   primary   ext4
 2      826GB   826GB  105MB   primary   ntfs            boot
 3      826GB   926GB  99.9GB  primary   ntfs
 4      926GB   960GB  34.3GB  extended
 5      926GB   960GB  34.3GB  logical   linux-swap(v1)

I got into this situation as follows:

  1. My vendor set up this dual boot computer using just the Windows boot manager which worked, but the version of Linux was old.
  2. So, I ran the Ubuntu 13.04 installer and completely deleted & reinstalled Linux on /dev/sdb1.
  3. When I tried booting into Linux, it came up at the grub prompt instead of fully booting.
  4. I tried manually booting using "set root", "kernel", "initrd", "boot", but it would boot only to the "(initramfs)" prompt.
  5. So, I booted on tne Ubuntu Live CD and purged and reinstalled grub. This worked.
  6. I rebooted and got only a black screen with a working mouse pointer.
  7. I rebooted again, and the system finally booted fully... but with the double boot manager as described above.

I would recommend using Boot-Repair

  • boot your computer on a Ubuntu live-CD or live-USB.

  • choose "Try Ubuntu"

  • connect internet

  • open a new Terminal, then type:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

  • Press Enter.

  • Then type:

sudo apt-get install -y boot-repair && (boot-repair &)

  • Press Enter

launch Boot-Repair from either :

1 The Dash (the Ubuntu logo at the top-left of the screen)
2 Or by typing 'boot-repair' in a terminal 

Then click the "Recommended repair" button. When repair is finished, note the URL (paste.ubuntu.com/XXXXX) that appeared on a paper, then reboot and check if you recovered access to your OSs. If the repair did not succeed, indicate the URL to people who help you by email or forum.

If that didn't work i would recommend using the that advanced options that can be found at the 0ffical Boot-Repair page at https://help.ubuntu.com/community/Boot-Repair

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.