I just bought a Dell 14z 5423, which uses UEFI/GPT and Intel Smart Response on the Windows 8.

I have been researching and studying how to use it as Dual boot.

Thanks to this forum I was able to install ubuntu 13.04 alongside with windows 8, disabling IRST and changing Sata Mode to AHCI.

Although I haven't was able to enable the ISRT yet, I, letting Sata Mode to ACHI, was able to boot both windows 8 and ubuntu.

Today I started it and ubuntu does not boot anymore. Nothing has changed. I could say that i installed some updates, by I had tested and it was ok.

Why it's been so troubly to have ubuntu + windows 8?

What do I have to do to have my ubuntu booting again?

What do I have to do to install ubuntu drivers for RAID (Intel Smart Response), and then how shall I use the accelerate mode in both discs?

I really appreciate your help.


You said "Nothing has changed. I could say that i installed some updates, by I had tested and it was ok." Those two sentences directly contradict each other, and the second is unclear -- in which OS did you install updates, and what type of updates were they? If I had to guess, I'd say that you installed Windows updates, and as a result, the Windows boot loader was re-registered as the primary boot loader for the computer.

If I'm right, this is relatively easily fixed within Windows:

  1. Launch an Administrator Command Prompt window. (You must have administrative privileges for this to work.)
  2. Type mountvol S: /S
  3. Look over the S: volume. There should be an EFI directory that contains various subdirectories, including EFI\ubuntu, which should have one or more files with names that end in .efi. Take note of what they are.
  4. Type bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi. Note, however, that you may need to change the filename. If Secure Boot is disabled, change shimx64.efi to grubx64.efi; and if you've installed another boot manager (such as rEFInd or gummiboot), you should change the entire pathname to refer to it. Whatever you use as a filename, be sure that it exists on S:.

There are other ways to deal with this problem, too, such as running Boot Repair from a Linux live CD or installing rEFInd. However you handle the problem, it's possible it will recur, so you should be prepared to repair the boot system in the future.

  • The updates I meant was on ubuntu 'apt-get update && apt-get upgrade'. It was working normally, the last thing I've done was boot on windows yesterday. Today, it was still running windows, and when I rebooted, ubuntu did not show up, it stuck on 'Loading initial ramdisk'. – Marlon Pascoal Sep 1 '13 at 17:45
  • I quite solved it yesterday changing Sata Mode to ACHI, but it is not working anymore. About the boot-repair, it was the way I found to display grub with ubuntu and windows, which was not showing up after ubuntu install – Marlon Pascoal Sep 1 '13 at 17:47
  • Do you have multiple Ubuntu options in your GRUB menu? If so, try loading an earlier kernel. It's possible that you've upgraded to a more recent kernel and the new one is buggy. If you can load an older kernel but not a newer one, then I recommend you file a bug report. One other suggestion: Re-run Boot Repair. It's conceivable that it did some tweaking to kernel options that haven't been applied to a new kernel, so running it again may help. – Rod Smith Sep 1 '13 at 23:09
  • I did boot-repair couple times and yes, I tried all the kernels avaiable there. I can't figure out why this happened, yesterday I was able to boot it on AHCI sata mode, I'd start installing my applications today. – Marlon Pascoal Sep 1 '13 at 23:41
  • I realized that if I enter setup, and just save it, ubuntu boots. But everytime I reboot I have to do it. It's very weird to me.. – Marlon Pascoal Sep 2 '13 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.