7

I have an HP ENVY 4500 e-all-in-one printer. It installed & prints successfully. But the scanner function does not work. Simple Scan says no scanner detected. I ran the command sudo sane-find-scanner & the scaner was also not detected.

I tied upgrading my hplip driver to the latest version, but it fails with an error that GCC is not installed. But I know for a fact GCC is installed.

Any help would be appreciated.

7
  • I tried doing this as sudo, but still did not work. I also edited the dll.conf file for sane. Since no help from ubunu users, I tried this answer that worked on my Arch system, but unsuccessfully on my Ubuntu 13.04 system.: wiki.archlinux.org/index.php/Sane#For_HP_hardware – LinuxPCplus Sep 2 '13 at 18:42
  • I'd try uninstalling gcc manually on Synaptic, reboot, and then installing gcc again using Synaptic. – user123492 Sep 2 '13 at 18:57
  • Yea, tried that already. No luck. – LinuxPCplus Sep 3 '13 at 2:45
  • Uninstall libsane, reboot and install libsane. – user123492 Sep 3 '13 at 13:33
  • Did that too. Let me clarify, I uninstalled ALL dependencies, then reinstalled them. None of that worked. – LinuxPCplus Sep 3 '13 at 20:24
3

Try this: it worked for me. I have the same printer and had same issues until I used the terminal command hp-setup.

For more information https://wiki.archlinux.org/index.php/Sane#For_HP_hardware

2

I had the same issue and the following steps resolved my issue. Setup the printer with:

hp-setup

and scan your document with:

hp-scan
-1

Just bought an HP Envy 4500. Worked out of the box with Ubuntu 14.04LTS - print, copy, scan. Simply added it as a printer with hplip.

1
  • John, would you mind adding some details? I'm trying to set up a 5660, but hp-setup won't see it at all. A detail of Step 1, 2, 3, etc., would be great. Thank you. – pythonlarry Mar 13 '15 at 22:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.