5

Firefox 23.0 canonical 1.0 already running not shutting down or starting up error. States its already running need to shut-down do system restart and close browser.

3
  • ok.. Open your terminal and run this command sudo pkill firefox. Then try to run firefox again.. – Saurav Kumar Aug 31 '13 at 16:27
  • 2
    +1, and just pkill firefox should do. – mikewhatever Aug 31 '13 at 16:35
  • if the two answers below which recommend killing the existing process do not work, because firefox isn't actually running, you'll want to remove the lock files as per one of the answers at askubuntu.com/questions/219234/… – matt freake Jul 23 '15 at 10:59
6

In one line:

rm ~/.mozilla/firefox/*.default/.parentlock

Explanations: You need to remove the .parentlock file in your mozilla profile:

cd ~/.mozilla/firefox
ls

This will show you one directory with a strange name, such as 12abc34d.default. Go to that directory and remove .parentlock.

1
  • This was helpful. I found that the *.default folder only had root:root permission. After deleting the .parentLock file, I could still not launch FF. I updated the permission on the *.default to my user and group root, this fixed it. FYI chown [user]:[group] -R – Twisty Jan 2 '18 at 21:52
3

If you like the UI route:
1. Click the Ubuntu Logo
2. Type "System Monitor"
3. Find Firefox in the list of running applications, right-click and choose to kill the application

1

Go to command line:

  • Run this command: $ top

  • you'll see some graphical output, then note the processID (PID) of firefox

  • then press 'k' to KILL the process
  • you'll be asked to enter the processID (PID) of process you want to kill.
  • Just enter the processID of the firefox, and you're ready to go ..!!

And you can use this procedure to kill any process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.