Every time at boot I get a message “Network service discovery disabled. Your current network has a .local domain, which is not recommended and incompatible with the Avahi network service discovery. The service has been disabled.”

Network service discovery disabled

What does this mean for me?

Wi-Fi is disabled.

  • 1
    This is a known issue: bugs.launchpad.net/ubuntu/+source/avahi/+bug/327362
    – tripleee
    Mar 27, 2015 at 5:23
  • Sometime in the past week, my Lubuntu 18.04 laptop started displaying this, simultaneously at work and home. Work uses a .local AD server (which isn't smart but eh, no messages before.) Could have been some update or software install which "triggered" it. host -t SOA local. does give a response from home, unsure what this would have been before. @int_ua "solution" worked for me.
    – rdtsc
    Nov 11, 2019 at 0:01

4 Answers 4


It looks like avahi-daemon is started when the network connection is established (/etc/network/if-up.d/avahi-daemon). This notification is informing you that mDNS (Avahi) has been disabled. It's only used for a small number of applications that only work on the local network, it won't adversely affect your internet connection or DNS.

The most well known use for mDNS is sharing music with Rhythmbox (or iTunes) over your LAN. It's an Apple technology, but it's largely been ignored in favour of uPNP or DLNA.

To disable it, you must edit the file /etc/default/avahi-daemon as root:

sudo -i
gedit /etc/default/avahi-daemon

and add this line (or change it if already exists to):


Source: http://ubuntuforums.org/showthread.php?t=1632952

  • And where exactly has been mDNS (Avahi) disabled? On my local network router? I think I don't use it, but I might have used to: I used to run an iTunes service on my FreeNAS server. Aug 31, 2013 at 15:40
  • @NickolaiLeschov What to do with your network router? It was disabled probably because does nothing to do. When you will run an app that will need it, that app should know how to enable it. Aug 31, 2013 at 16:15
  • 2
    It seems, like here are several good reasons, Why you shouldn't use .local in your Active Directory domain name., so just disabling the warnint is not a good solution.
    – rubo77
    Oct 8, 2015 at 5:36
  • I did this but I still get the error on login
    – djb
    Feb 5, 2016 at 17:11
  • This solution worked for me running 16.04, very simple and effective. I've rebooted the laptop several times and all seems well. Thanks
    – RoyS
    May 20, 2017 at 0:36

According to the Avahi wiki there are two workarounds:

Better one:

In /etc/avahi/avahi-daemon.conf uncomment and change the line with domain name to


Second one:

In /etc/nsswitch.conf delete a [NOTFOUND=return] text.

  • Not working for me. Oct 19, 2013 at 9:22
  • Both of them? Are there any changes in the wiki?
    – int_ua
    Oct 20, 2013 at 14:48
  • Looks good, please add it as another answer :)
    – int_ua
    Oct 21, 2013 at 13:12
  • have not worked for me on ubuntu 14.04
    – Decebal
    May 7, 2014 at 7:44
  • Link rot alert! EDIT: Seems to be temporary... Feb 4, 2017 at 16:01

It probably says that Avahi is disabled because you have a .local domain and Avahi doesn't work very well with this.

Avahi is a zero conf protocol like Apples Bonjour commonly used if you have Macs on your network or if you want to chat with others on your local network without logging in to a server like Google Talk or MSN Messenger.

You can read about the problem here.

You could probably just ignore it or configure your network to use another domain name then the default .local.

  • 5
    At least here in Finland, the DNS of a major ISP (Sonera) has been configured to claim authority for .local domain. Check host -t soa local. - you should get not found: 3(NXDOMAIN). For example: host -t soa local. will test Google DNS. A broken DNS server will return something like local has SOA record localhost. hostmaster.sonera.fi. 20130911 14400 7200 604800 900. Mar 2, 2014 at 21:23
  • So please add how to "configure your network to use another domain name"
    – rubo77
    Oct 8, 2015 at 5:37
  • @rubo77 well, if your ISP tosses upon you wrong dot local domain, there is no howto except making ticket with them and requesting to remove that from their configuration for you.
    – silpol
    Sep 15, 2016 at 16:07

While there may be multiple causes, I began getting the exact same error on ubuntu 14.04 after a change of ISP. Some naughty ISP's use local domain addresses for their DNS servers as explained here. My ubuntu box's network uses a manual configuration so setting the DNS to my router's IP instead of the ISP's DNS server address fixed the problem. Internally, the router is using the ISP's locally domained DNS server but ubuntu is unaware and happy. More evidence here that this is the ISP's fault

In short, check if your ISP is using local domain non-routable DNS IP addresses. If so, switch DNS provider on ubuntu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .