13

I've set up a new server running a fresh installation of Ubuntu Server 13.04. I've installed xubuntu-desktop and tightvnc. My ~/.vnc/xstartup configuration file contains the following:

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
x-window-manager &
# Fix to make GNOME work
export XKL_XMODMAP_DISABLE=1
# /etc/X11/Xsession
startxfce4 &

The VNC server appears to running fine, and I am able to connect to port 5901 successfully using the TightVNC Java client.

My concern is that a lot of icons in the GUI are broken/missing, as shown in this screenshot:

screenshot

Am I missing some commands in my xstartup file?

Ideally, I would like to be able to have the GUI be the default Xubuntu session (with the Xubuntu theme, etc) and not a bare-bones Xfce session.


Update:

For reference, opening the XFCE appearance settings, it shows that the Greybird theme is selected and the icon set is elementary Xfce.

theme icons

4
  • 1
    I had a similar issue on a recently rebuilt headless 13.04 box at my work (in particular no icons at all in thunar - but thumbnails OK). I never found a solution, except that it seemed to be something to do with the failure of the xfsettingsd daemon to start (starting it manually caused the icons to flash up briefly, then it immediately died). Maybe this will point you towards a resolution - my pragmatic solution was to switch to an LXDE session. Aug 31, 2013 at 14:02
  • Yeah, from my research, it appears that a lot of people have the same problem with XFCE and VNC across multiple releases of Ubuntu. LXDE sounds like a good idea, but I don't like to give up easily. ;)
    – iglvzx
    Aug 31, 2013 at 14:12
  • @steeldriver I have abandoned XFCE and am now using LXDE without any issues. I spent the good part of the day Googling and trying different proposed solutions, but I could not get anything to work for Ubuntu 13.04.
    – iglvzx
    Sep 12, 2013 at 17:53
  • Is it possible that you are running Xfce as root (where some other icon theme was chosen) but start xfce4-settings-manager as user?
    – landroni
    Jan 23, 2014 at 12:52

3 Answers 3

6

I had the exact same issue and finally managed to resolve it. The weird thing was it is simply the order of these two lines in the configuration file.

# Starting X session must come before export statement
/etc/X11/Xsession

# This line comes second
export XKL_XMODMAP_DISABLE=1
1
  • This just worked for me. I've been pulling my hair out for years on this. xubuntu 18.04 Mar 30, 2020 at 20:01
1

you properly didn't load vncconfig script for vnc session

add

vncconfig -iconic &

to your xstartup for xubuntu-desktop, your xstartup should look like

#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
startxfce4 &

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
1
  • Worked like a charm! Though I was able to authenticate, I had a gray desktop with nothing on it. Setting up my ~/.vnc/xstartup exactly as you have it here, allowed me to see the desktop, where I chose to use the default settings.
    – gone
    Feb 14, 2020 at 0:03
-1

You can try installing the Greybird theme which is the default theme in Xubuntu with the command:

sudo apt-get install shimmer-themes

Then choosing "greybird-git" (not Greybird!) from the XFCE settings

For the icon theme, use this command:

sudo apt-get install xubuntu-icon-theme

Then choose the "Elementary XFCE Dark" theme (or similar) from the XFCE settings

1
  • This does not help me as the xubuntu-desktop package installed the xubuntu-artwork package, which includes the shimmer-themes and xubuntu-icon-theme packages.
    – iglvzx
    Aug 31, 2013 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.