What is zeitgeist-fts?!
It's always in the 3 top positions of memory usage (competing with Firefox and Compiz) . After a fresh boot it uses about 30 MB, but after some hours or a day, it goes above 300 MB and stays there !

The file of this process is located at /usr/lib/zeitgeist/zeitgeist-fts. I don't know what this thing does, but if it doesn't break any functionality, I would be really happy to remove it, because memory capacity is very precious to me.

Edit: I'm using Unity desktop on Ubuntu-12.04.2 LTS.

  • 1
    14.04 fresh install. After two days zeit... it is using 5Gb from 6Gb Ram :-)
    – dstonek
    Apr 16, 2016 at 17:23
  • 1
    For me it is using 2 GB out of total 4GB and moreover it is overflowing to swap :(
    – Trect
    Jul 22, 2019 at 14:45

4 Answers 4


What zeitgeist is

Zeitgeist is a service which logs the users’s activities and events, anywhere from files opened to websites visited and conversations. It makes this information readily available for other applications to use in form of timelines and statistics. It is able to establish relationships between items based on similarity and usage patterns by applying data association algorithms such as “Winepi” and “A Priori”

Zeitgeist is the main engine and logic behind GNOME Activity Journal which is currently seen to become one of the main means of viewing and managing activities in GNOME version 3.0

Source: Wikipedia

How to quick-fix it

As zeitgeist is a journal, it'll grow bigger day after day, leading to ram consummation problem.

The easiest way to solve this is to make some clean by removing the current journal to let a new one take its place. It's not dangerous and can be done with a single command-line :

rm -r ~/.local/share/zeitgeist/

Or with your your file browser (ctrl + h to display .hidden file) :

in your Home folder (~/) > .local > share, and remove zeitgeist

Your Ram consummation should be back to normal after a reboot. You can stay with this solution and wait until the next zeitgeist problem (probably in some years), or try one of the following solution.

How to disable it

(without remove it)

Better would be to disable it instead of removing it.

First open startup applications and UN-tick zeitgeist from startup automatically.


If you don't see zeitgeist in startup applications, open a terminal (CTRL+ALT+T) and issue the following command

sudo sed 's/NoDisplay=true/NoDisplay=false/g' -i /etc/xdg/autostart/zeitgeist-datahub.desktop 

Turn off Record Activity

Open Privacy settings and turn off Record Activity. enter image description here

Last but not least, remove the execution bits to prevent application from running.

From a terminal (CTRL+ALT+T)

sudo chmod -x /usr/bin/zeitgeist-daemon
sudo chmod -x /usr/bin/zeitgeist-datahub
sudo chmod -x /usr/lib/zeitgeist/zeitgeist-fts

The zeitgeist-fts could be in an different location from what is specified here. If you cannot find it, issue the following commands one-by-one to locate the correct path.

sudo updatedb
locate zeitgeist-fts

How to remove it

Following might be dangerous and remove also some important packages for Dash functionality.

Run sudo apt-get remove zeitgeist* in a terminal. It might remove a few related packages, but so long as you don't see anything suggested for removal that you don't want, you should be fine.

As per comments: you will lose unity functionality (I was not sure how much when I first wrote the answer) if you remove zeitgeist. So, I suggest you just disable logging.

If you don't need unity to function correctly, you can go ahead and remove zeitgeist, and just use the classic session (from the login screen).

You can also blacklist everything or turn off logging altogether.

Source: AskUbuntu

  • Thanks for the detailed answer. I opted the "Disable It" option, but I only did remove it from startup and turned-off 'Record Activity'. I didn't remove the exec permissions of the files, I thought it was too much :) ... Let's see how it goes and I'll give feedback again ... Just to make sure: This doesn't break any functionalities of Dash or Unity? Right?! Aug 30, 2013 at 18:50
  • 1
    No, if you only disable it without removing it, it doesn't break any functionalities on Dash. I did this (checked) myself before posting ;-)
    – NickTux
    Aug 30, 2013 at 20:14
  • 1
    The two operations I did didn't fix the problem and again 'zeitgeist-fts' went above 300 MB memory usage! ... Guess I have to remove the exec permissions of the 'zeitgeist' files! Sep 3, 2013 at 12:57
  • I had a huge memory leak (700+ MB of memory after one use of Unity Dash) because of Zeitgeist and I fixed it by disabling recording activity & restart and activating it again. Without this service, working on the computer is nastier (tried it, also), I use "Recent files" very often, so I do not wish to navigate to some folder each time I open a frequently used file. In the last 2-3 days, zeitgeist-fts uses less than 5 MB of memory. I guess there was some error in the index file and disabling&reenabling the service fixed it. PS: I use Ubuntu 14.04 LTS.
    – conualfy
    Jan 13, 2015 at 16:21
  • 1
    In ubuntu 14.04 it doesn't find the last file. It exists however /usr/lib/x86_64-linux-gnu/zeitgeist-fts, I guess it is this one ??
    – Antonello
    Oct 4, 2015 at 16:39

There are times when zeitgeist-fts starts acting up really weird. The issue is very erratic and not really easily reproducible at times.

One workaround is to delete the fts.index directory

rm -rf ~/.local/share/zeitgeist/fts.index/

then it will try to reindex it. I guess the high memory consumption is due to broken index. Deleting the index will force zeitgeist-fts to try to reindex it again.

  • 1
    Thanks for the tip ... Although I think I will be better of just disabling zeitgeist all together. Aug 31, 2013 at 7:17

After disabling activity recording (as explained by @NikTh), remove zeitgeist data altogether:

rm -rf ~/.local/share/zeitgeist/

This folder will be recreated on next reboot with empty data and zeitgeist process won't take so much memory.


In Ubuntu 18.04 Bionic, to disable service restart after reboot:

cd /usr/lib/systemd/user
sudo ln -snf /dev/null zeitgeist-fts.service

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .