0

I have followed the instructions from here exactly. I was able to increase the speed and sensitivity of my trackpoint. However, those settings would revert itself to the default upon restart. In other words, the settings don't save.

What am I doing wrong? I'm using Ubuntu 12.04 on a Lenovo ThinkPad X120e that has an AMD 64-bit processor. Please someone help me with this, as I cannot use the touchpad, and I will have to dump Linux and go back to Windows if I don't have proper trackpoint support.

  • I'd say you've messed something up with the udev rule. Please edit add the question above and add it, if you want help. – mikewhatever Aug 29 '13 at 22:25
0

I have no idea why, but an udev rule didn't work for my x200 either. What did work however is this upstart-job from the german ubuntuusers-wiki.

just create the file /etc/init/trackpoint.conf as root

    sudo gedit /etc/init/trackpoint.conf

with the following content:

description "Trackpoint-Settings"
env TPDIR=/sys/devices/platform/i8042/serio1/serio2
start on virtual-filesystems
script
  while [ ! -f $TPDIR/sensitivity ]; do
    sleep 2
  done
  echo -n 200 > $TPDIR/sensitivity
  echo -n 150 > $TPDIR/speed
  echo -n 0 > $TPDIR/press_to_select
end script

change the path in the second line to the path where your trackpoint-settings are saved. It should be one of these:

  • /sys/devices/platform/i8042/serio1
  • /sys/devices/platform/i8042/serio1/serio2
  • /sys/devices/platform/i8042/serio4/serio5

and adjust the echoed values (sensetivity and speed 0-254; press to select 0 or 1).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.