3

this is very weird. I open google earth and search for "athens, greece" for example, and even though it will through a pin on top of the correct location, the google earth globe will turn and zoom in towards a location in the sahara desert!

Could this be related to the regional settings on the computer?

nass@stardust:~$ locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=el_GR.UTF-8
LC_TIME=el_GR.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=el_GR.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=el_GR.UTF-8
LC_NAME=el_GR.UTF-8
LC_ADDRESS=el_GR.UTF-8
LC_TELEPHONE=el_GR.UTF-8
LC_MEASUREMENT=el_GR.UTF-8
LC_IDENTIFICATION=el_GR.UTF-8
LC_ALL=

What else could it be?

3

I can verify that by changing the regional settings to en_US.UTF-8 the problem vanishes. The obvious difference is that greek uses 'comma' as a decimal separator and that mixes google earth somehow.

I am not sure if this is a bug on google-earth's code (since this error does not show up in,say, windows OS) or in ubuntu. But they should probably be notified.

1

This solution worked for me:

https://bugs.launchpad.net/ubuntu/+source/googleearth-package/+bug/1160289

These are the instructions I followed:

"I created a script and named it "earth.sh" (without the quotes).

  sudo gedit earth.sh

and placed the following lines inside it:

 #!/bin/bash
 LANG=en_US google-earth

Then I placed said script inside /opt/google/earth/free:

 sudo cp earth.sh /opt/google/earth/free

Then I opened /usr/share/applications/google-earth.desktop:

 sudo gedit /usr/share/applications/google-earth.desktop

and changed the "exec" command to "/opt/google/earth/free/earth.sh".

Now google earth opens and the search function works ok even if the language is not US english."

Definitively its an issue with the regional settings.

  • Thank you! This got me on the right track. But instead of your exact steps, I just edited /opt/google/earth/free/googleearth (a shell script) and inserted LANG=en_US right after the interpreter line. One change and it all works. – Zdenek May 27 '17 at 20:32
0

Between the last line starting with a # and FindPath(), insert LANG=en_US and save

it works just fine on my Lubuntu 18.04 / Google Earth Pro 7.3.1.4507 (64-bit) with Swedish locale. There are no problems with non-english letters (Å, Ä, Ö)

So that part of the file now looks like this:

# Function to find the real directory a program resides in.
LANG=en_US
FindPath()
0

With google-earth-pro-stable-7.3.2.5776-0.x86_64, I use LC_NUMERIC=C to fix the problem while keeping the language of the application unchanged. You can run:

LC_NUMERIC=C google-earth-pro

or edit /opt/google/earth/pro/googleearth to add this just after the header of file :

export LC_NUMERIC=C

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.