2

I need to low-level format floppies with an external usb floppy drive in ubuntu 10.04 (or later) server.

I have tried the tools that come with util-linux-ng, and contain (specifically) fdformat.

Unfortunately these tools are written to use /dev/fd* devices, and not /dev/sd* that is used with the usb floppy drives I have on hand.

Alternatives to using the tools would be appreciated (note, the computers I have at my disposal do not have floppy connectors on the main board, so please don't recommend using a "real" floppy drive).

for example, I know dd works to zero the drive, but I suspect I need a copy of a working, blank formatted floppy as the if= parameter. I have my doubts this would be a robust, ongoing solution for actually writing out the tracks on the floppy.

the answers are not at: How can I get a USB floppy drive to work? How to format a USB or external drive? ...and lots of others

  • 1
    Have you tried 'gparted'? – Marc Aug 29 '13 at 0:42
  • just try: 1. unmounting the floppy (umount /dev/fd*) and 2. overwriting the floppy (sudo dd if=/dev/zero of=/dev/fd*). if you are not sure what "fd*" you are targeting, try lsblk and locate the one of 1.44 or 2.88 MB – Yoran Jansen Nov 19 '17 at 19:04
1

Try mtools. apt-get install mtools

Edit the /etc/mtools.conf file to have one of the drive letters point at your usb floppy drive. For me the usb floppy was /dev/sdg (Use dmesg to determine this.)

# # Linux floppy drives
#drive a: file="/dev/fd0" exclusive
drive a: file="/dev/sdg" exclusive

Then mformat a:

mformat a:

  • worked perfectly with xubuntu 16.04. Will have to verify at the client that actually needs it, using older ubuntu versions. Also appears to automatically format it with fat12 filesystem – derekshaw May 17 '17 at 23:27
3

The fdutils web site refers to http://www.geocities.jp/tedi_world/format_usbfdd_e.html for usb floppy drives.

  • 1
    It is packaged, apt-get install ufiformat . Then check that the floppy is umounted and ufiformat <device> – Emmanuel Apr 24 '16 at 17:05
  • This works on xubuntu 14.04. Later tested on 16.04. – derekshaw May 17 '17 at 23:54
-4

Have you tried gparted as the root (sudo) user? I use this tool daily for all kinds of drives yet I a floppy - I have not.

sudo apt-get update && sudo apt-get install gparted
sudo gparted

Look to the top right to find your drive. If Linux can mount it - Gparted should be able to format it!

  • 2
    gparted is for partitioning hard disks, not low level formatting floppies ( which are not partitioned ). – psusi Aug 29 '13 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.