I am using an asus q500a with ubuntu 12.04 unity; linux kernel with windows 8 dual boot.

I will note that all of my hardware works flawlessly in windows 8 which came with the computer, I just don't like windows. I am running a dual boot with windows on ntfs and ubuntu on ext4. Windows on uefi.efi.

  • When I boot to ubuntu the first time I press the h key it doesn't work, but it works fine after that. This problem is consistent.

  • Sometimes certain on-board shortcuts on my keyboard will auto-press a key instead of performing their intended function. For example, Fn+F12 is supposed to increase my volume. Sometimes it presses q repeatedly instead.

  • Same problem with brightness controls for screen and keyboard (but other keys besides q like h). Logging out and logging back in fixes the problem temporarily. Tried kernels as well as 3.9.11 and it doesn't seem to make much difference. Also tried gnome-panel and xubuntu-desktop. Not much difference except xubuntu seems to have slightly different issues with my hardware.

  • The most annoying problem is sometimes (usually when opening or closing an app) my mouse will get stuck on grab mode. When this happens I cannot click, it just wants to grab windows and drag them around. When this happens I cannot click shutdown, or log off. Space and enter do not seem to work either. Most of the functionality of my keyboard fails when this happens.

  • I am able to open terminal with Ctrl+Alt+T but when I try to type anything it starts opening tabs on top of the screen such as "file" or "edit". The only thing I have found to work is Ctrl+Alt+Del to log out, then waiting 60 seconds for it to do so automatically.

  • Logging out temporarily fixes the problem. I have tried switching to gnome-panel and xubuntu-desktop, as well as the previously mentioned kernels with little difference.


I have now tried Ubuntu 12.10desktop, and Xubuntu 13.04 and experienced the same problems.

sudo uname -a:

Linux seth-Q500A 3.5.0-41-generic #64~precise1-Ubuntu SMP Thu Sep 12 16:50:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

sudo lsb_release -a:

LSB Version:    core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.3 LTS
Release:        12.04
Codename:       precise
  • When I boot into Ubuntu it says Could not write bytes: broken pipes. Seems to be a driver issue but I am having a hard time figuring out how to get drivers for my system.
    – hydroxide
    Nov 1, 2013 at 7:13
  • I figured out if I hold ctrl+alt and press f6 them f7 it goes into shell line, and resets xorg which works around the mouse grabbing and ctrl being held down problems.
    – hydroxide
    Nov 9, 2013 at 3:15
  • Got xorg updates from software update and it no longer says "Could not write bytes: broken pipes" when I boot, and boot time has been significantly decreased. It does still take at least 20 seconds though.
    – hydroxide
    Nov 9, 2013 at 3:17
  • Okay, it is back to saying the above statement about broken pipes. It seems to be random when it says it.
    – hydroxide
    Nov 15, 2013 at 23:59

3 Answers 3


I suggest you to install following packages if they are not already installed:

  • If you are not able to write in terminal, it is possible that you you will be able to type in CLI Mode. Press CTRL+ALT+F1 to go to command line interface. Login using your username and password.
  • Execute following commands to install above mentioned packages if not already installed:

    $ sudo apt-get update
    $ sudo apt-get install xserver-xorg-input-multitouch
    $ sudo apt-get install xserver-xorg-input-synpatics
  • Restart your system:

    $ sudo reboot now
  • I hope your problem will be solved after login.

  • If it still exists, you can give a try to Jockey, a package which scans & installs all proprietary drives. You can find it in /usr/share/applications directory. No need to go through command line. Just browse the folder. Run it and wait for sometime till it finishes scanning your available drivers. Restart again and notice the difference.

More information about Synaptic Touchpad:

Synaptic Touchpad Configuration

  • I made sure I had all those things installed. Ran into a problem with broken packages, which I worked around by manually installing dependancies. apt-get autoclean/autoremove didn't fix it. Still having the same problems.
    – hydroxide
    Sep 2, 2013 at 0:14
  • 1
    you fix broken packages by executing this command: sudo apt-get -f install here -f is to fix. You can also use Synaptic Package Manager to fix your broken packages. Find out here: help.ubuntu.com/community/SynapticHowto Sep 2, 2013 at 7:12
  • Okay, I believe the xserver-xorg-input-synaptics did fix the "grabbing" mouse problem. Thank you, that was the worst. I am still experiencing the same keyboard problems mainly involving fn+f3,f4,f5,f6,f11,and f12. These are for adjusting keyboard leds, screen brightness, and volume. The h key still doesn't work the first time I press it. I have tested this in win8 and there are no problems so it's not hardware.
    – hydroxide
    Sep 2, 2013 at 22:59
  • 1
    Did it get locked by some buttons..! I recommend you to install Indicator Applet which will indicate you if it is locked. You can also give a try to this command: sudo dpkg-reconfigure $(dpkg -l | awk '{print $2}'|grep "^xserver"|tr '\n' ' ') just copy and paste it in your terminal.. Sep 7, 2013 at 8:39
  • 1
    You like to play around.. :P Anyway, try these commands: sudo dpkg-reconfigure $(dpkg -l | awk '{print $2}'|grep "^xserver"|tr '\n' ' '), sudo dpkg-reconfigure -a and sudo update-initramfs -u Sep 17, 2013 at 16:27

Asus Q500a with 14.04 LTS. Reload Xorg Multitouch and Synaptics. Problem solved for me. I do not use the touchpad, have a wireless mouse instead. Touchpad disabled in UEFI.


Not only does all my hardware work fine in 14.04, but it seems to be working in a fresh 12.04 desktop installation. Kudos to Canonical.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.