I'm unable to connect to only some networks (password/SSID triple check) with my default wireless adapter Broadcom BCM4313 802.11b/g/n (using Proprietary driver Broadcom STA) while running Ubuntu 12.04.

In the general case I'm able to connect succesfully to any network.

However, there are at least two wireless networks I can't connect to:

  • I never had any problem to connect to them before
  • I changed the configuration (WPA2 instead of WEP or nothing, SSID change/hide)
  • Now, when I try to connect I'm able to enter the SSID and password but the connection never establishes*

*I got the little connection animation in the status bar for ~3-5min then ubuntu prompts me for the password, tries to connect for ~3-5min, etc.

Using an ethernet wired connection, an USB Manufacturer Realtek RTL8191S WLAN Adapter, or booting on Windows and using the default adapter in those networks do not cause any problem.


I just upgraded to Ubuntu 13.04, problem persists.

lspci -nn -d 14e4: outputs

02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

(I can't find the drivers options in 13.04)

  • Have you tried to run Wireshark to see what is happening when trying to connect to the networks? That might provide some clues here for you. Any output from the logs (/var/log/dmesg) might prove useful as well. – freecode Aug 28 '13 at 13:44
  • I'll tell you what I can find with wireshark – Aurélien Ooms Aug 28 '13 at 13:52
  • Please edit your question to add details of your wireless card from: lspci -nn -d 14e4: I wonder if STA is the correct driver for your device. – chili555 Aug 28 '13 at 13:58
  • @chili555 edited – Aurélien Ooms Aug 29 '13 at 10:15
  • @freecode Problem solved, didn't have the time to check what was going on with Wireshark. – Aurélien Ooms Aug 29 '13 at 13:16

I believe the Broadcom STA driver is incorrect for your device 14e4:4727. Please get a temporary wired ethernet connection, open a terminal and do:

sudo -i
apt-get remove --purge bcmwl-kernel-source
apt-get install linux-firmware-nonfree
echo brcmsmac >> /etc/modules

Reboot and your wireless should be operating correctly.

| improve this answer | |
  • Couldn't believe it, it works! – Aurélien Ooms Aug 29 '13 at 13:14
  • Is it possible the driver was behaving well with older technologies like WEP and broken with WPA2? – Aurélien Ooms Aug 29 '13 at 13:17
  • Anything is possible, I guess. Certain drivers work better with certain Broadcom devices and some not at all. In this case (14e4:4727), brcmsmac works much better. – chili555 Aug 29 '13 at 13:21
  • I just tried this with the same hardware and Ubuntu 12.04 and I still get the dreaded "Authentication required by wireless network" dialog cycling. – nomen Oct 29 '13 at 20:03
  • @nomen--Please start a new question and include your kernel version: uname -r – chili555 Oct 29 '13 at 20:30

If I remember correctly when I had same problem with same driver on my old Dell Inspiron 6400 - there where 2-3 drivers and deactivating one that is not working and activating other one until find one that was correct for my hardware - solved the problem.

I hope this will help

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.