This is my issue.

I just got a brand new laptop (Windows 8 Samsung).

This does not have a cd drive and I wanted to do a dual boot with Windows and Ubuntu.

I did a "install from flash drive approach" and I choose "Install alongside windows 8" option.

It got installed successfully but the ubuntu was very laggy and slow.

Since I like Ubuntu much I decided to erase my windows completely and install Ubuntu as the only OS which now I am unable to.

Because for some reason

My flash drive does not appear in the list of boot options

It says something like

"Option 1 : Windows xxxxx"

"Option 2 ubuntu 12029mb etc"

But when I choose Ubuntu it takes me to the GRUB screen back and I am unable to reinstall Ubuntu.

Is there some way I can make this bootable flash drive to come back again as one of the bootable options so that I can wipe everything and keep ubuntu as the only OS ?

  • You need to use your BIOS' boot menu to boot from the USB flash drive. If it is reaching the bootloader for the hard drive, it's already too late. Which key you press will depend on your system's chipset, but commonly F1, F2 or F12 (it should be displayed on the screen when you first start your computer). Alternatively load the BIOS settings screen and set your boot disk order to have USB devices first, if you can. – Aaron D Aug 27 '13 at 19:17

Sometimes the BIOS does not recognize the USB flash Drive.

For my computer, I have to plug the USB flash Drive, go into the BIOS, save and exit, and then, press F12(depending of your computer) for the boot menu to appear and it's there.

Also, I had trouble with the EFI... Read this here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.