After installing Ubuntu 12.04 LTS on my HP Folio 13 I cannot get wireless to work. My kernel is 3.8.0-29-generic and my wireless module is a Broadcom BCM4313.

After running rfkill list all:

0: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

The wired connection works fine. The driver activation for Broadcom STA wireless driver fails every time. in the log it says

FATAL: Module wl not found.
FATAL: Error running install command for wl

After running lspci -nnk | grep -iEA3 "(wireless|network|wlan)":

02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless
Network Adapter [14e4:4727] (rev 01)
Subsystem: Hewlett-Packard Company Device [103c:1795]
Kernel modules: bcma
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader [10ec:5209] (rev 01)

I have also tried this method and it did not work: Installing Broadcom Wireless Drivers.

  • Please include the output of lspci -nnk | grep -iEA3 "(wireless|network|wlan)" in your question for exact identification of the device including the numeric IDs and the kernel driver in use now.
    – gertvdijk
    Aug 27 '13 at 16:26
  • Specific instructions for your device (14e4:4727) seems to be covered at several Q&A on this site. I think this will help: askubuntu.com/a/265886/88802
    – gertvdijk
    Aug 27 '13 at 17:01
  • Was just about to paste that one, I think that's the one. Aug 27 '13 at 17:02
  • The fix for the bug is now ready and in the 12.04 repositories. lists.ubuntu.com/archives/precise-changes/2013-September/… (This eliminates the need for the posted workarounds, so voting to close)
    – gertvdijk
    Sep 24 '13 at 8:16

Important note

An updated revision of bcmwl-kernel-source that should fix the issues on kernel 3.8.0.xx has been rolled out to the precise-updates archives. Please make sure to upgrade your system before considering any of the workarounds posted in this Q&A.

(thanks, @gertvdijk for the headsup)

Original answer

The issue you are dealing with seems to mainly appear on Ubuntu 12.04.3 LTS with the backported kernel 3.8.0-xx installed.

Please take a look at this bug report. As you can see it's a known problem and many different workarounds exist.

What worked for me was installing the latest bcmwl-kernel-source from Raring. You can find this package here. Make sure to download the right one for your system, e.g. this one if you have an amd64 machine.

You can install the package via:

sudo dpkg -i ~/Downloads/bcmwl-kernel-source_6.20.155.1+bdcom-0ubuntu6_amd64.deb

Of course you will have to change the path to the deb file in accordance to where you downloaded it to.

You might have to execute the following command afterwards to get your wireless up and running:

sudo modprobe wl

Source: http://ubuntuforums.org/showthread.php?t=2155228&page=2&p=12765664#post12765664

  • Worked for me, raring version solves it. Thanks so much.
    – erandros
    Sep 7 '13 at 20:43
  • 1
    @Erandros You are welcome :). Glad to have been helpful. Sep 8 '13 at 10:26

There is a bug in precise for wl driver. You may try this patched package which solves the issue. Or you may try b43 driver as well.

Just download your architechture package amd64 or i386 and install it using software-center or gdebi or sudo dpkg -i PACKAGE_PATH. If you get dependency error do sudo apt-get install -f OR you may install dkms first which is required.


  • I have tried installing the b43 driver, that never worked for me either. When I go to the link you suggested, there are several package file links. How do I know which one to use? I'm a little new to all of this. Thanks. Sep 8 '13 at 19:16
  • I have been using the patched package and it works. By the way your lspci says LP-PHY so maybe firmware-b43-lpphy-installer may work for you. Sep 8 '13 at 19:19
  • But how do I get the patched package? I did try the firmware-b43-lpphy-installer, but I couldn't get it to work. It kept saying that b43 was blacklisted. I asked a different question about this issue, but couldn't really figure it out. I thought the problem was that I was using wubi, which is why I decided to install Ubuntu on its own partition. Sep 8 '13 at 19:25
  • Updated the answer with procedures. Sep 8 '13 at 19:29
  • Thanks for doing that, although I'm still not entirely clear on what to do. I have a 64 bit architecture, does that mean I should get the file bcmwl-kernel-source_6.30.223.30+bdcom-0ubuntu2eugenesanprecise1_amd64.deb? And, if so, once I do that, do I install it by typing gdebi, and then that file name? I appreciate your patience on this, I haven't used gdebi, dpkg, or dkms before. Sep 8 '13 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.