0

I have an Epson LX-300 Printer Driver, but I can not get it to print on the full width of a regular US Letter page. Whatever I configure, the printer just prints about 60% of the page width. As if the page were very small, leaving large empty spaces. I have tried printing from Firefox, Chrome, and OpenOffice. I have tried setting the "Paper Size" to different settings. I have taken out all margins. I have used "Adjust to fit on page" and printed on "100%" (and 150% and 50%⁾. I have installed the printer under Ubuntu 10.10 using this tutorial: http://all-about-ubuntu.blogspot.com/2008/12/epson-lx-300-printer-driver.html, and I have tried using this driver: http://www.openprinting.org/printer/Epson/Epson-Dot_Matrix. I have also tried by just using Ubuntu default setting.

All of this has given no results. I can not get this printer to print on the full width of the page.

Anybody any idea?

1
  • A couple of questions (1) What happens when you try print a test page from within the Printer Properties dialog? (2) Are you setting the printer settings in the application or from the system menu?
    – jwernerny
    Apr 6, 2011 at 20:55

2 Answers 2

0

You probably have the wrong driver. Install a different one by going to: Administration > Hardware > Printing. Try all drivers from Epson, one of those should do the job.

1
  • This in fact worked... changing it to Epson 9-pin series!
    – user6019
    Jun 11, 2011 at 13:38
0

Did you try to print a test page as asked by jwernerny in comments section?

What is the printer model? I have Lx 300+ and I not facing this problem. I could print a test page also in a decent way.

I used the same driver PPD file Epson-Dot_Matrix-epson.ppd.zip for the printer Epson Lx 300+ and I am able to print in the whole page.

I did some setting changes in firefox where I fire prints. On the address bar, typed about:config

Type header on the filter bar, then right-click each of those prefs and select Modify, then backspace or use Delete to wipe the characters - then click OK.

Type footer on the filter tab, then right-click each of those prefs and select Modify, then backspace or use Delete to wipe the characters - then click OK.

Search for margin then:
print.print_extra_margin Change from 90 to 0 print.print_margin_bottom delete and make 0 print.print_margin_left delete the current value and make it 0.04 print.print_margin_right delete the current value and make it 0.1 print.print_margin_top delete and make 0

Repeat the all of the above changes for settings specific for the printer ( eg: print.printer_Epson-Dot-Matrix.print_margin_top)

Left and right margins I chose based on my needs. Header/Footer I wanted to wipe off, so I removed it.

But then my print was what I expected to get.

Please let me know if this works or come back with more questions so that we can resolve it.

You must log in to answer this question.