The default font size in the non-X terminals is too small for me.
How can I changed it permanently ?

I've ran sudo dpkg-reconfigure console-setup in TTY 1, but seems to only effect the 'gnome-terminal' running courtesy X in TTY 7...

UPDATE ... I've just checked more carefully... It actually did changed the font, from 8-14 (it only offers 8 14 and 16).. The width of each char did not change; they only got taller (ie. fewer lines on the screen) ...
I'm getting 160 characters across the screen (on a 17"CRT). That makes it impossible for me... So it seems like it may be a screen resolution issue, and not a font issue (unless I can choose a larger font size somehow)

So the question is now.. Either: How do I change the font size to larger than offered by sudo dpkg-reconfigure console-setup ... Or: How can I reducet the screen resoluton of TTYs 1-6 ?


You can force your TTYs to run in different resolutions and font sizes by adding vga=xxx to your boot line. xxx should be replaced by any of these values:

Colours   640x400 640x480 800x600 1024x768 1280x1024 1600x1200
 4 bits |                  0x302      
 8 bits |  0x300   0x301   0x303    0x305    0x307     0x31C
15 bits |          0x310   0x313    0x316    0x319     0x31D
16 bits |          0x311   0x314    0x317    0x31A     0x31E
24 bits |          0x312   0x315    0x318    0x31B     0x31F
32 bits |  

Some of these do not work on some hardware. When it fails you will be presented with a list of alternatives.

edit: hwinfo Install hwinfo can show you scancodes you can use with the following command:

sudo hwinfo --framebuffer | grep Mode

Resolution = columns, lines:

640 x 400 = 80 x 25
640 x 480 = 80 x 30
800 x 600 = 100 x 37
1024 x 768 = 128 x 48
1280 x 1024 = 160 x 64
1600 x 1200 = 200 x 75

To make it permanent you can add the vga=xxx to your bootloader options. The file you need in 11.04 is /etc/default/grub and you need to run sudo update-grub after any changes (from: How to remove GRUB selection? ).

  • I've tried every which way, but the right way, it seems.. eg.. I added vga=0x314 (and tried =314) as the last line in /etc/default/grub... ran sudo update-grub.. and nothing changes.. I still have 160 characters across the screen when I press Ctrl+Alt+F1... I'm using 10.04 (which I believe grub 2.. but one of your links said that although vga=xxx is depricated, it should still work in grub2.. Have I missed something obvious?
    – Peter.O
    Jun 10 '11 at 15:42
  • I will have a go at this soon! my notebook so my new one needs settinng up 1st ;)
    – Rinzwind
    Jun 11 '11 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.