The wireless doesn't work on my Toshiba Satellite C55-A5281. The device originally came with Windows 8, but I removed it snd installed Ubuntu. Wireless does not work "out of the box" and there are no proprietary drivers to enable in the manager. Wired connection however does work, along with the keyboards and it's functions-brightness, sound, etc. I posted about this in the forum last-week, but no other people were able to help. http://ubuntuforums.org/showthread.php?t=2168927


If this is your device, it is covered by the very new driver rtl8188ee:

Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8179] 

Verify your device with the terminal command:

lspci -nn

If so, you can compile this driver in 13.04. Please get a temporary wired ethernet connection and do:

sudo apt-get install linux-headers-generic build-essential

I suggest you download this to your desktop: http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.11-rc3/backports-3.11-rc3-1.tar.bz2 Right-click it and select 'Extract Here.' Now open a terminal and do:

cd ~/Desktop/backports-3.11-rc3-1/
make defconfig-rtlwifi
sudo make install
sudo modprobe rtl8188ee

Your wireless should now be working. You will have compiled the driver for your currently running kernel only. When Update Manager installs a later linux-image, after reboot, re-compile:

cd ~/Desktop/backports-3.11-rc3-1/
make clean
make defconfig-rtlwifi
sudo make install
sudo modprobe rtl8188ee

If the message logs say you need firmware:

dmesg | grep rtl

Download and install it with:

wget http://mirror.pnl.gov/ubuntu//pool/main/l/linux-firmware/linux-firmware_1.106_all.deb
sudo dpkg -i linux*.deb 
sudo modprobe -r rtl8188ee && sudo modprobe rtl8188ee
  • For some reason after the first attempt it worked until I rebooted. I tried again and after a few reboots this still seems to have worked. – David Jan 17 '14 at 6:17
  • I get an error when running make defconfig-rtlwifi: Generating local configuration database from kernel ...Kernel version parse failed! Makefile:40: recipe for target 'defcongif-trlwifi' failed make: *** [defcongif-trlwifi] Error 1 – Trae Oct 29 '16 at 7:36
  • @Trae This guide is quite old in Linux years. I suggest you start a new question and tell us what problem you are having with your wireless. I doubt that backports-3.11 is an answer in late-2016. – chili555 Oct 29 '16 at 13:37
  • @chili555 My issue is pretty much identical to the one you answered here, but here's an updated question: askubuntu.com/questions/843280 – Trae Oct 29 '16 at 20:04

Had that as well on the live environment, but a little different!!!

On my Acer TravalMate 4650 in live environment, the internal blue-tooth suddenly worked for the first time ever(Windows XP was not working with the internal bluetooth so I used a USB-extension instead), but WLAN not, even with the driver installed and started. After I installed it stayed that way. The first reboot of the local installed, WLAN was turned on automatically again. I turned it off on installing hardware and updates to save power, because I used a cable instead for Internet connection.

I installed my USB-HSDPA(3G)-Modem, worked out of the box...after playing around with some drivers and needing to restart again, WLAN turned on again...but than it suddenly connected and worked!!!

I'm using Kbuntu 13.04, it was a hell on installing it, but now it works so nicely...my windows gaming PC is starting to collect some dust, till I'm back on Linux...

...but here is my tip, as you use Linux in Single Boot, maybe try out a different distro of Ubuntu? Like Kbuntu is actually build to support all kind of Laptop Hardware, for example. The GUI is dream for Windows Fans...it's like the best features of XP and 7 combined in one powerful OS. Hope this may help you... ;3)

  • 2
    So, basically, what you're saying is "apply system updates using another internet connection and reboot"? You really don't have to explain your problem for that. Also, using another offical Ubuntu derivative will not change anything in terms of hardware support - all use the same kernel and networking libraries. – gertvdijk Aug 27 '13 at 10:27
  • Well...I tested out Ubuntu 13.04 Linuxwelt and Kubuntu 13.04 So far Kubuntu only worked on Laptops and similar, only one desktop system...Ubuntu works great when enough graphical power is there, but otherwise a lot of work is needed to optimize it. Ubuntu only worked with P4 or more...as described in it's system requirements...all systems have them and they are different from distro to distro, that's way there are so many different distros, different looks and eye-candies, as all have different hardware goals. – Red Starfox Aug 28 '13 at 9:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.